Uploaded Uno onto Yun

So today i was playing with my Arduino Yun and Arduino Uno, by mistake i uploaded my UNO sketch with UNO board selected onto my YUN port, and it exploded, i got the repeated cb!=fb problem, and i just cant fix it i’ve tried almost all fixes ive found and nothing. Now i can’t even connect to my YUN wifi :’(

I consider it lost, unless someone can help me. But i’ve got a question:

Why did my YUN let me upload a sketch with UNO board selected?, i’ve made that mistake before (with DUE and UNO) but it will failed the upload.

Regards

Just a thought... If your sketch is sending data out the serial port right off the bat, it could be interrupting the Linux boot process (the Arduino processor is connected to a console port, and there are a couple places during the boot process where you can press a key to stop the boot. It might be worth a try holding the Arduino processor in reset until you finish booting, then releasing it while trying to upload a sketch using WiFi.

It's a Hail Mary pass, but this is what I would try before giving up:

  • Power down the Yun
  • Put a jumper wire between the RESET and GND pins on the shield connectors
  • Power up the Yun, and give it a minute or two to reboot
  • Get ready to upload a safe sketch (like blink?) using WiFi
  • Just before starting the upload, remove the jumper between RESET and GND
  • Hit the sketch upload button
  • Hope it works...

Holding the Arduino processor in reset will eliminate serial port interference as a reason for the Linux side to not boot. If that works, then loading a sketch over WiFi will not only clear out the offending sketch, but will also reload the bootloader in the Arduino processor, letting you start from a clean slate.

I don't know if it's going to help, but I don't think it can hurt to try.

dyrschatten:
::::SNIP::::
I just cant fix it i’ve tried almost all fixes ive found and nothing. Now i can’t even connect to my YUN wifi :’(
::::SNIP::::

@dyrschatten,

It’s not clear to me what you mean when you say “i’ve tried almost all fixes ive found”

You should try Shapeshifters suggestions. You can get more detail by reading these short instructions.
Resetting the processors (AR9331, WiFi, and 32U4)

Then start over, plug in your Yun the USB, run this sketch, and hit the ‘‘Wifi Reset button’’ (for 5-10 seconds).
YunSerialTerminal

Let us know how it goes.
Post results from the YunSerialTerminal, if you are still having problems.
Please use markup when posting results.

Jesse

arduino_markup.png