Uploading a sketch cannot be completed

Hello
I am new to Arduino and electronics.
I have a problem when uploading my sketch: the sketch starts uploaidng, the green advancing bar seems full, but the IDE keeps giving the message :“uploading” on the left low corner and it is stuck there. Please see the error messages below.
I have tried:
Diffrent sketches. (including the basic Blinking sketch).
Different (two) Arduino Nano board, one of them completely new - nothing ever connected to it.
Different USB ports in my computer.
Different USB connecting cables.
Getting “board info” which works fine. (meaning that the connction is good, I guess)
In one of the boards, I connected a led with tesistor to 13 and Grd, and got blinking in a one second interval (if I understood correctly, some vendors upload the “Blinking” sketch as the default sketch on the board.
I have no problem uploading a sketch to Arduino UNO using the same computer, IDE and usb connection. (with the appropriate adjustment of “Tools/Boards” of course.

The error message:

Arduino: 1.8.14 Hourly Build 2020/10/09 12:33 (Windows 10), Board: “Arduino Nano, ATmega328P”

Sketch uses 4680 bytes (15%) of program storage space. Maximum is 30720 bytes.

Global variables use 55 bytes (2%) of dynamic memory, leaving 1993 bytes for local variables. Maximum is 2048 bytes.

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x10

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x10

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x10

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x10

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x10

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x10

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x10

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x10

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x10

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x10

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

What am I missing?

Many thanks,
Doron.

Have you tried the '328p old boot loader' option under tools -> processor ?

yes,
Have tried all 3 options there.
With anything other then the ATmega328p option, I am getting an immediate error message.
"An error occurred while uploading the sketch"

thanks

Hi,
Any takers?
I am almost done with the build, (Peopeller LED Pendulum clock using Arduino NANO), but the sketch will not finish the uploading process.
Please see the details in the opening post above.
Will appreciate any advice.
Doron

doron2:
Getting "board info" which works fine. (meaning that the connction is good, I guess)

What does the board info say?

Hi,
Thanks.
Board info:
"BN: Unknown board
VID: 0403
PID: 6001
SN: Upload any sketch to obtain it"

Hello,
Have tried today to remove the IDE and re-install the last version, ver 1.8.13
Same results as described above.
Have no idea where to go from here.

Hi
Have tried today to install the IDE on a different computer.
Same problem as above.
The only common thing are the 2 Arduino NANO boards. Havae used two different usb cables. Could it be that both boards are somehow defective?

have installed the ch340 driver, which seems to solve the problem