Uploading Bootloader into brand new Chips

Hi,

I bought brand new virgin atmega328p SMD version from digikey,
im having troubles burning a bootloader into them

i tried many ways but with no luck,
may somebody tell me whats the best way to do that?!

You will have to describe the ways that you tried, what you used to program the chip, wiring, schematic, possible error messages etc. etc. etc.

What do you have for a Programmer?

I used Arduino uno as ISP programmer & USBASP as well.
my new and virgin ATMEGA328 is connected to External 16Mhz Oscillator SMD
And Pullup Resistor of 10K on the reset plus a 0.1uf to pin 20.

im using AVRDUDESS as main software,
Fuses are set as :
0xFF
0xD9
0xFF
0x3F

when Flashing a program using AVRDUDESS it works fine but with no bootloader.

if i try to burn bootloader or upload a sketch using Arduino IDE it does not work !!?

what i did wrong ?

please find attached images

Post a pic of your wiring as well. Most people use a crystal and 2 caps, or a resonator. Using an Oscillator, which outputs 0-5V levels and needs Power & Gnd, requires different fuse settings.

As attached below i tried both :
crystal with two caps and an SMD one , same as on arduino.

both worked fine when i uploaded the sketches on them via AVRDUDESS,
but not with arduino IDE, since i couldn't burn a boot-loader on them !!!



Well, the bootloader is just another sketch. Try loading that with avrdudess.

Read Nick Gammon's comprehensive article on doing this (www.gammon.au).
Goes through every step on what's involved.
I've just replaced a damaged 28-pin SMD 328P on a Nano using Nick's method. Mine was a "bare" chip from RS, worked first time. Nick covers the very minimal requirements to get going.

CrossRoads:
Well, the bootloader is just another sketch. Try loading that with avrdudess.

Thank you for your assistant,

kindly view below my problem, i made a screen capture of it :