uploading code on arduino uno

I just started to get the error of avrdude: stk500_getsync(): not in sync: resp=0x00 I'm not sure what that means or how i should proceed to fix it.

Have you selected the correct board and serial port? If this is not the problem: Please turn on verbose for upload and dump the content of the bottom part of the arduino IDE.

Alright, i did that what should i be looking for, or not looking for?

Nvm I found my problem it appears to be the usb port as it is a bit finicky with my mouse and it looks like the same for the arduino, switched ports and it works fine. I did not think it was the port at first as it never came up with the error of "wrong com" or anything like that. thanks for your help though

I have similar problem, i checked com port and board, every thing is proper.I even tried pressing reset before uploading nothing is working. I tried shift + upload and i got this:

avrdude: Version 5.4-arduino, compiled on Oct 11 2007 at 19:12:32
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

System wide configuration file is “D:\Softs\arduino-0023\hardware/tools/avr/etc/avrdude.conf”

Using Port : \.\COM18
Using Programmer : stk500v1
Overriding Baud Rate : 115200
avrdude: ser_open(): setting dtr
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51] [20]
avrdude: Recv:
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

avrdude done. Thank you.

Help me with this. Thanks a lot in advance.

Why are you using 0023?

I used arduino 1.0.3 and not working for that also. I tried shift + upload and it says:

avrdude: usbdev_open(): did not find any USB device "usb"

Thanks a lot :)

What board do you have, where did you get it, and what board are you selecting in the IDE?

I have Arduino UNO from Italy. I m selecting the same board in the IDE. Thanks a lot for your reply.

The board can say anything. I asked where (store/vendor) you bought it.

I bought that from element14 It was working fine for a year but now i have this problem Thanks a lot

Loopback test results?

Sorry can you tell me how to get the loopback results? Thanks a lot

Sticky link at the top of this forum.

I m not getting the letters typed in the terminal. But i just see the Rx Led on when the key is pressed. So what should i do next?
Thanks a lot

That suggests your serial to usb chip is damaged.

Can i get that fixed?
If yes tell me what to do?

I got a new arduino with loopback test working but i m still getting avrdude: stk500_getsync(): not in sync: resp=0x00 and on shift + upload i m getting avrdude: usbdev_open(): did not find any USB device "usb"