Uploading error message


I had recently purchased Arduino PCB and mounted the components and also burnt the Bootloader into it using another programmer.

When I tried to upload "Blink" Program,

  1. The error on Arduino sketch is always as follows

avrdude: stk500_getsync(): not in sync: resp=0x00 avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

  1. The preference page looks like this. ... target=arduino ... serial.port=COM1 ... last.sketch1.path=C:\Documents and Settings\Administrator\My Documents\arduino-0017\arduino-0017\examples\Digital\Blink\Blink.pde ... serial.parity=N serial.databits=8 board=diecimila ... upload.using=bootloader ...

serial.stopbits=1 serial.debug_rate=19200

  1. Also tried with other Boot programs

They differ in resetting the Board , one is with 3 blinks initially, the other is 700ms ON and 7Sec OFF(repeats).

  1. I presume that there is no functional problem in the Board.

ClKOuT is 1/8th of 16Mhz.(observed) and Boot loader Blinks are noticed.

5.Board Selection and Baudrates(19200) are adjusted properly

Board is "Arduino diecimila ... w/ATMEGA168" and Baudrate is 19200 at "Preferences" page and "Device Driver(PORT properties)"

6.Even tried with USB port and Serial Ports

In both cases I observe 2msec High to low pulse ( total 3 times) at RXD pin of MCU Also observed init(Reset) pulses at Pin1 of MCU. TXD pin is always High and does not change.

  1. I tried both Cross and Straight RS232 cables.( I think Straight cable must be used.Am I correct?)

  2. Also followed Trouble shooting guide.

I agree there is response problem in the board, if , someone can guide me further, it would be highly appreciated.

Thanks in advance



This has been resolved by using ADABoot_168.hex bootloader from http://www.wulfden.org/TheShoppe/freeduino/ADABOOT.shtml Thanks for the coders for their effort.

with regards to all supporters of Arduino SCP