Uploading Error

I am getting the following error while trying to upload a sketch to my Arduino Diecimilia 168. Any ideas?

java.lang.NullPointerException at processing.app.debug.AvrdudeUploader.getProgrammerCommands(AvrdudeUploader.java:97) at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:58) at processing.app.Sketch.upload(Sketch.java:1498) at processing.app.Sketch.exportApplet(Sketch.java:1465) at processing.app.Sketch.exportApplet(Sketch.java:1420) at processing.app.Editor$46.run(Editor.java:2219) at java.lang.Thread.run(Thread.java:619)

What sketch? What operating system? What version of Arduino IDE?

Sorry, should have included this stuff.

Any sketch, even the simple Blink example causes this error.

I am using Windows XP.

I have tried on both Arduino v17 and 18.

I am also quite certain I have the correct com port selected.

Are you as certain that you have the correct board selected?

I am selecting the correct board, and just to be sure I tried every other board in the list....same error. Just tried v14 with no luck either. Argh.

Maybe try deleting your Arduino preferences file? The location is in the preferences dialog, but delete it after you've quit Arduino.