uploading error

I too have the same problem. Please anyone help me to upload programs in arduino.
I am a beginner. So i can’t understand what is loop back test.

What problem?

Post the full text of any and all error messages.

these are what i get when i try to upload

Arduino: 1.6.8 (Windows 7), Board: "Arduino/Genuino Uno"

Sketch uses 1,066 bytes (3%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
Invalid library found in C:\Users\sriraman\Documents\Arduino\libraries\Blink: C:\Users\sriraman\Documents\Arduino\libraries\Blink
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x53
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x53

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
Invalid library found in C:\Users\sriraman\Documents\Arduino\libraries\Blink: C:\Users\sriraman\Documents\Arduino\libraries\Blink
Invalid library found in C:\Users\sriraman\Documents\Arduino\libraries\Blink: C:\Users\sriraman\Documents\Arduino\libraries\Blink

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Arduino: 1.6.8 (Windows 7), Board: "Arduino/Genuino Uno"

Sketch uses 1,066 bytes (3%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
Invalid library found in C:\Users\sriraman\Documents\Arduino\libraries\Blink: C:\Users\sriraman\Documents\Arduino\libraries\Blink
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x53

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
Invalid library found in C:\Users\sriraman\Documents\Arduino\libraries\Blink: C:\Users\sriraman\Documents\Arduino\libraries\Blink
Invalid library found in C:\Users\sriraman\Documents\Arduino\libraries\Blink:
This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Moderator: merged topics.

Do not start a new thread if not needed please, thank you

Why using such an old IDE version? We're on 1.8.5 now.

Though I don't think that's related to the issue - IIRC 1.6.8 was fine.

Possible causes:

  • Wrong board selected (try all the '328p-based boards - nano and pro mini too - sometimes clone manufacturers put the wrong bootloader on the '328p)
  • Wrong port selected (make sure the port you have selected disappears from the list when the Uno is unplugged)
  • Something connected to 0, 1, or Reset
  • Missing bootloader or hardware damage on '328p.

It generally implies that the drivers and serial adapter IC is working.