Uploading firmware on Arduino Uno R3?

Hey guys, I’m a newbie in the world of Arduino. I recently purchased an Arduino Uno R3 for the Arduinome/Chronome that I’m making. I’m having a lot of trouble trying to upload the firmware.

BTW I’m using OSX 10.6.8, and I have access to Windows, which I prefer, but the instructions were given for OSX so here I am, using my old mac that I rarely even look at…

I’ve tried loads of stuffs which I don’t even recall doing, so there might be weird stuff installed…
Here’s the list of the installed things from macports

localhost:dfu-programmer-0.6.0 [censored!]$ sudo port installed
Password:
The following ports are currently installed:
automake @1.13.1_0 (active)
expat @2.1.0_0 (active)
gdbm @1.10_2 (active)
gettext @0.18.2.1_0 (active)
libiconv @1.14_0 (active)
libusb @1.0.9_0 (active)
libusb-compat @0.1.4_0 (active)
ncurses @5.9_2 (active)
perl5 @5.12.4_0+perl5_12 (active)
perl5.12 @5.12.4_1 (active)
pkgconfig @0.27.1_2 (active)

http://arduino.cc/forum/index.php/topic,92148.0.html

I’m following the instructions listed in above site, but I’m having trouble executing ‘make’ for compiling DFU 0.5.4… I’ve done the patch which gives support to 16u2, and then when I enter ./bootstrap.sh, it returns:

autom4te: -: no such file or directory
aclocal: error: echo failed with exit status: 1
configure.ac:8: warning: AM_INIT_AUTOMAKE: two- and three-arguments forms are deprecated. For more info, see:
configure.ac:8: automake
configure.ac:8: error: version mismatch. This is Automake 1.13.1,
configure.ac:8: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:8: comes from Automake 1.10. You should recreate
configure.ac:8: aclocal.m4 with aclocal and run automake again.
configure.ac:8: warning: The ‘AM_PROG_MKDIR_P’ macro is deprecated, and will soon be removed.
configure.ac:8: You should use the Autoconf-provided ‘AC_PROG_MKDIR_P’ macro instead,
configure.ac:8: and use '(MKDIR_P)' instead of '(mkdir_p)'in your Makefile.am files.

and when I enter ./configure, it returns:

checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for a thread-safe mkdir -p… m4/install-sh -c -d
checking for gawk… no
checking for mawk… no
checking for nawk… no
checking for awk… awk
checking whether make sets $(MAKE)… yes
checking whether to enable maintainer-specific portions of Makefiles… no
checking for gcc… gcc
checking for C compiler default output file name… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ISO C89… none needed
checking for style of include used by make… GNU
checking dependency style of gcc… gcc3
./configure: line 3343: syntax error near unexpected token LIBUSB_1_0,' ./configure: line 3343: PKG_CHECK_MODULES(LIBUSB_1_0, libusb-1.0 >= 1.0.0 , have_libusb_1_0=yes, have_libusb_1_0=no)’

and when i type make, it returns:

make: *** No targets specified and no makefile found. Stop.

I would appreciate any sort of help!!!
And one more thing, the latest version of DFU is 0.6.0. Should I use this instead of version 0.5.4? And I’ve tried compiling 0.6.0 too, but the results were the same as v0.5.4.

here is the link for uploading the firmware from the FlipMu site which hosts info on Arduinome:

http://flipmu.com/work/arduinome/instructions/uno-atmega-8u2-serial-number/

Have a great day guys!