Uploading firmware to ATMEGA328PB

Total newbie user here. I'm trying to install firmware onto a board with an ATMEGA328PB using the Sketch->Upload function. Whenever I try, I get a "Done Uploading" response, but the firmware remains unchanged. This is doubtlessly a naïve question, but what am I doing wrong?

I tried all of the options available under Tools->Board, but I always get the same results. What step am I likely to be missing?

Is there any upload error showing? (the rest of this post assumes no error reported)

The upload process uploads the code, then reads it back to make sure it's been updated. I think it is most likely that the new version of the firmware that you're uploading behaves the same way as the old version in your test.

I suspect if you tried uploading blink, you'd find that that works fine.

It says "Uploading complete." However, when I query the firmware for a version number, it still reports the old number. I verified that this number is correct within the firmware.

I also turned verbose mode on to determine which hex file is being uploaded. I examined the hex file and determined that this one contains the proper version number... but the number reported is incorrect.

Never mind. I figured out what was going wrong. This particular firmware was also storing its version number on the EEPROM, which was causing all sorts of confusion. Many thanks anyway.

As i said above :wink:
If it says upload complete, the new sketch is in there, and the problem is elsewhere

Glad its working.