Uploading in Arduino Pro

Hello,

I am new in Arduino and I have some problems in connecting to my board. I have an Arduino Pro 328 at 3.3V 8Mhz. Unfortunately I can´t upload anything (for example the blink sketch). The error message is:

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I have read the troubleshooting file but I can´t fix the problem. I am using a usb-ttl converter (with a CP2102 chip)and I have tested this connecting Tx with Rx and looking the ECO in hyperterminal. I have configured the converter to 19200 bauds because I read in some posts this velocity for Arduino (I have try with 9600 baud too).

I have been using Arduino sw 0022 and I set in tools my board and the port COM that I have used.

In my Arduino board I see a green LED near 13 PIN that blinks when I supply the board. I goes slowly when it starts, but it goes faster after few seconds, and then it stops suddenly. But I have read that it blinks continously, so, is the bootloader working fine?

I have read that Arduino Pro does not reset automatically, so I have tried to push the reset button during the upload process in different times in the process, but I have not been able to upload anything in any case too.

Anybody could give any clue, please?

Hold down the Reset button until you see the "Binary sketch size:" message, then release it.

Auto-reset should work if you have the right cable connected the right way.

The boards.txt file from 0.22 says the baud rate for the "Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ ATmega328" is 57600. It should be using that baud rate automatically when you do an upload.

Thanks Johnwasser,

I have setted the serial port to 57600 bauds, 8 data bits, no parity, 1 stop bit and no flow control. Unfortunately it seems that doesn´t work yet. Also I have tried to push the reset button until "Binary sketch size:" message, but doesn´t change anything. And finally I have checked the reset wire to the FTDI converter, but it seems to be all right.

Any more clues?

Best regards.

It is possible that there is a sketch that is swamping the USB port.

  1. Unplug the USB connector
  2. Hold down the Reset button
  3. Plug in the USB connector
  4. Click on the Upload button
  5. Wait for the "Binary sketch size" message
  6. Immediately release the Reset button

I have followed carefully these instructions several times but I could not get any better result.

I have tried with other PC too. One with XP and one with windows 7, but the same result has been observed. I may try with Ubuntu in a few days, but I am not sure that it will go better. I am going to try in some minutes upgrading to Arduino software 1.0 too.

Also, I purchased other board, so I tried with the second unit, but it has the same behaviour.

Finally, I borrow a logic analyzer and I looked at the frames during the upload process. I observed data frame flow from PC to Arduino board, but it seems that Arduino is not answering anything.

I think that I am doing a mess with something, but I have no idea about what. The problem seems to be that Arduino is not answering or the converter is not working fine (at least it is sending something). Has anybody problems with any model of usb-ttl converter?

try adding a diode between RESET and +5V as per this thread:
http://arduino.cc/forum/index.php/topic,64256.0.html

“try placing a diode between RESET and 5V on the POWER connector, with the cathode (end with the bar) towards the 5V. it will need to be a small-signal one, such as a 1N914, 1N4148. note that a 1N4002 or similar power diode will likely NOT work.”

Ok, thanks.

I have tried with Ubuntu in another machine and it seems to work fine, so I think that is a driver problem in my computer.

I have the same adopter and it works pretty fine with XP OS.
If I am not mistaken this message often appears if the Tx is connected to Tx (should be connected to Rx)

But that it is really strange if in Linux everything goes well.
Especially if converter was recognized by XP (as COM port).

stoikovky:
Ok, thanks.

I have tried with Ubuntu in another machine and it seems to work fine, so I think that is a driver problem in my computer.

i'd still say try adding the above mentioned diode, the handling of the RESET signal is dependant, in part, on the o/s and driver. and report back the results either way (fixes the problem or makes no difference).