Uploading issue

Hi all,
I’ve been playing with several different ways to use a 2.4" display, and wanted to attach it to a 3.3v controller. I first worked it with an ESP 8266 and the demo’s worked fine. But for my purpose I didn’t feel the ESP 8266 was the best choice. I have a 3.3v Pro mini, that I have constantly had problems with uploading. So I tried taking a 5v version and powered it at 3.3v. The demo sketch uploaded and ran, BUT I received the message in the attachment named IDE 1.8.7.

As stated, the demo sketch uploads and runs fine. Also note that the board selected is a Pro Mini @ 5v, even though I’m running it at 3.3v. (again, I can’t get my 3.3v to upload) Can someone explain why I get this mesage?


As an experiment I remembered my older laptop had IDE version 1.8.4 loaded on it. I installed the Adafruit library and examples on to it, connected the USB cable from the Pro Mini/ FTDI to it, again, it uploaded fine, ran fine, but this time the verbose output is shown in attachment IDE 1.8.4:

IDE 1.8.4.txt (4.22 KB)

IDE 1.8.7.txt (4.4 KB)

That is quite interesting. I've never seen an explanation of what causes the verification error problem.