uploading library

Trying to use a 20 x 4 LCD I2C display. Using the inbuilt library/examples (online editor) loads in a pde file that will not compile. I copied the code in to a new ino file and got that to upload. But it doesn't work. Other sites suggest using a liquidcrystal_I2C library that has an lcd.begin() function instead of lcd.init but begin() is not in the inbuilt library. Tried to upload a different liquidcrsyatli2c library and got error

Libraries that could not be imported:
[] parse library.properties: library.properties not found

Very confusing …..

solved it. Despite all examples saying lcd displays are 0x27 - 0x20 this one is 3F !! Had to use I2C scanner to find this out.

Hi abenn666,
I have exactly the same problem with my sketch. I am using a library "LiquidCrystal_I2C".
It compiles OK on my computer but if I try using the web editor I get an error. After a bit of looking I can see that this library is not available. However if I try to upload the library I get this error.

[] parse library.properties: library.properties not found

It happens because a properties file is missing or incorrect. This is were my very limited abilities terminate.
Even after reading the explanation I have no idea what is required and it is beyond me.

How did you resolve this ?
I don't understand your reply "Despite all examples saying lcd displays are 0x27 - 0x20 this one is 3F"



I2c devices have an address and some use different ones despite seeming like the same device.
@abenn666 used the device scanner sketch available in the examples to find the correct one for his device.
His device was located at 0X3F and not as expected in the 0X27 to 0X20 range.

There is a topic on the library properties file

Many "older" libs may not have the properties file and you can either write one yourself or if you downloaded a lib then ask the maintainer at the source you downloaded it from to update it.

Also attached a help file that may be of use to you in the future for importing libs from third parties.

Importing sketches and libraries v2.pdf (287 KB)

Regarding the "[] parse library.properties: library.properties not found" error:

Unlike the Arduino IDE, Arduino Web Editor requires even libraries in the 1.0 format to contain a library.properties file. In order to import this library, you'll need to:

  • Unzip the library's .zip file.
  • Delete the library's .zip file.
  • Create a file named library.properties in the library's root folder.
  • Open library.properties in a text editor.
  • Add text to the file following the Arduino Library Specification: Arduino IDE 1.5: Library specification · arduino/Arduino Wiki · GitHub. Don't worry too much about exactly what you fill the fields with, it's mainly just the presence of a valid library.properties file that's important.
  • Save the file
  • Zip the library folder
  • Import the .zip file in Arduino Web Editor.

Please let me know if you have any questions or run into any problems while following those instructions