Uploading problem: "avrdude: ser_open(): can't set com-state for..."

Hi everybody,

I know that other people faced similar problem and there are already quite a lot of posts about it but surprisingly none of the answers I saw up to now could help me.

I have an arduino esplora which worked very well until one day I tried to upload a program on it and got this message:

avrdude: ser_open(): can't set com-state for "\\.\COM3"
Une erreur est survenue lors du transfert du croquis

(sorry I don't have the right english translation)

These are all the attempts and observations I could make:

  • The problem is not due to my code itself because I tryed to upload it on another anduino card and it worked very well

  • I've tryed to connect the board on different ports, on different computers, with different USB cable, and I've tried several operations concerning the computer's ports (refresh them, uninstall/reinstall, rename...). None of this worked so obviously the problem is not due to the computer either.

  • I've tried every possible ways to press the reset button: right before uploading, during uploading, reset then unplug then upload, pressing reset button for a long time etc... it didn't change anything.

  • The Rx light is always on, the Tx light is always off, the display is white (also tried without the display connected: didn't change anything).

  • A priori nothing seems broken on the card. (Maybe there is a protocol to check the tension between some pins or some connexions, to check if there is a poor electrical contact somewhere?)

A friend thought maybe I could kind of "totaly new flash" my arduino card but I didn't find much about that on the internet. Does anyone know something about flashing an arduino card?

If anyone has an idea about what could be wrong with the card, and above all HOW it could get wrong, I would be greatful!

Do you think that unpluging an arduino card during uploading a programm could have cause this? (I don't think I've done that but I thought about this because I once inadvertently did it with an HY-TTC which was quite bad and we had to "repair" it per CAN...)

Thanks in advance for you answers and have a great day!

Isi