Uploading problem on Arduino Nano (avrdude: stk500_getsync() )

Good Morning to everyone,
I am an engineering student, new to Arduino programming, and in the last days I've been having problems with uploading sketched to the arduino nano that I have always worked with.
When I plug it in it looks fine, leds light up as usual, but whenever I try to upload a sketch I get the following error:

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x9c

I have seen many posts about it, but none of the solutions given was working fine for me. Serial communication is working, the port and the bootloader are the right ones, I checked everything, but still when I upload a sketch the RX led blinks 3 times, then stops, and blinks 1 time for each new attempt.
Moreover I have tried to re-burn the bootloader but it's giving problems with the wiring.
Do you have any solutions? Or do you think that I burned it somehow?

Thank you very much!

Hello,
I had similar problem
In Arduino
Go in Tools Menu
When you added Arduino Nano
After back to tools and change also the processor to ATMega 328P (old boot loader)
and was able to upload on Nano board