Uploading problem (the pc to the Arduino Uno)

Hey ! I have an error when I want to upload my code to my board.
Even going to "Tools" -->Port, I have my two ports, but I don't have the brackets (Arduino). I then supposed that my pc didn't recognize the card in its usb port, so I tried on different other computers, I also tested different cards and cable, but it still didn't work...

Would you have any idea ?
Thanks very much in advance!

Does a new COM port appear in Device Manager (or its equivalent if not using Windows) when you plug in the Arduino ?

Mmmh, no nothing, but the leds on the card are on

If the LEDs are on then it is getting power, but if a new COM port does not appear when the USB is not being recognised, possibly due to a problem with its driver

Which Operating System are you using ?

Oh I see ... Windows 10

Try this

Open Device Manager by right clicking on it in Control Panel and select "Run as administrator"

When it opens select View/Show hidden devices. Plug in the Arduino. Is the Device Manager display refreshed when you do this ? If so, does a new Unknown Device show up in the display ?

1 Like

It didn't refresh, but I have two unknown devices that appeared in the list once I displayed the hidden devices. But, when I tried to make that with my keyboard the Device Manager display refreshed it self

Maybe this helps: Cannot upload to my brand-new Arduino Nano - #12 by sterretje

1 Like

Oh okay, thank's

In fact, I don't have a yellow triangle, only a question mark

image