Uploading sketch error

Hey guys, I get this error every time I upload a sketch to my arduino.

Binary sketch size: 1010 bytes (of a 30720 byte maximum)
avrdude: verification error, first mismatch at byte 0x0000
0x0c != 0x00
avrdude: verification error; content mismatch

The sketch seems to still run fine but this error worry's me. any ideas?
I'm running 0021 and my board is a Duemilanove.

I'm running 0021 and my board is a Duemilanove.

And your sketch is?

It does it with every single sketch. Even the example sketches. Doesn't matter what it is. I've had this arduino ever since they came out with the Duemilanove and have never had it come up with this error. It's not the computer either because I've tried it on three different ones with the same result.

Three different computers or three different Arduinos? If its the same Arduino and same cable, the problem is with either the cable or the Arduino.

I tried another cable and that's not it. Guess I'll be buying another atmega328.

If you haven't already bought a new one, I was just having the same problem but when I tried a new usb port and changed the serial port to COM4 instead of COM3 it worked fine :slight_smile: