Uploading the sketch for a servo motor failed

I am trying to upload a sweeping sketch to the Arduino Uno board. The board is an original one from Ardunio, not a clone, and I have used it several times on the same computer and had no issues at all.

I get the following error message:

avrdude: ser_open(): can't set com-state for "\.\COM3"
An error occurred while uploading the sketch

I checked the device manager, and the port COM3 was there and connected to Arduino; I uninstalled the port, plugged it off then plugged it in and it directly showed the connection to the board on COM3; also I tried updating the driver and it showed that it was up-to-date, but none of these worked. Where could the issue be?

This is a Windows OS com port issue, this is the wrong subforum for such issues.

(Unless, perhaps, you overloaded the USB port)

How can I tell if I overloaded the USB port? and if that's the case, then how can I solve it, please?

It will drop out automatically - don't use Windows, no idea what it does in detail.

USB cannot provide enough power for a hobby servo, so don't even try it. Budget at least 1A per servo
to be provided separately to the Arduino power.