Uploading through bluetooth "programmer is not responding"

Hey everyone,

I am trying to make something that will let me program my arduino over bluetooth using an HC05 module. I have been following this guide.

Connecting works just fine. When trying to upload I get the following error:

Arduino: 1.8.12 (Windows 10), Board: "Arduino Uno"

...

avrdude: Version 6.3-20190619
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM5
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x19
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x19
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x19
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x19
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x19
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x19
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x19
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x19
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x19
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x19

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

The connections are like this:

Arduino (TX) = 1k resistor = HC 05 (RX)
Arduino (RX) = HC 05 (TX)
Arduino (5v) = HC 05 (Vcc)
Arduino (GND) = HC 05 (GND)
Arduino (RESET) = Capacitor (0.1uF) = HC 05 (STATE)

Programming the HC05 with AT commands did not give any errors (see link for the specific ones I used). Does anyone know what is causing this?

Update:

followed this guide and build the circuit: Arduino Remote Programming Using A HC-05 Bluetooth Module | Paynter's Palace

Works now. I've looked at more than 10 guide by now at least and this is the only one that worked entirely for me, plus it doesn't require soldering. Highly recommend this one.