Uploading to Attiny with an Arduino

I'm trying to use my Arduino Uno to upload a program to an Attiny. I uploaded Arduino ISP to my Arduino, but when I try to up load Blink onto the Attiny, I keep getting a error that says:

Wrong microcontroller found.
avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85
avrdude: Expected signature for ATtiny85 is 1E 93 0B
Double check chip, or use -F to override this check.

My board is set to ATtiny85 (internal 1 MHz clock), and when I tried to use burn bootloader to configure the ATtiny to run at 8 MHz I get the same message.

The BS2 and PAGEL errors are ok.Did you override check using 'F'?

Check out the video tutorial by Matt Richardson on Youtube How to : shrinkify your arduino projects(How-To: Shrinkify Your Arduino Projects - YouTube). I have tried it and it works.

here you can find a description, where the arduino-ide is used to programm an attiny:

(ok it is in german and it costs 1,50€)

it try to give you a short overview:

  • select in the menu tools->programmer the option "arduino as isp"
  • selcect the attiny as board
  • hold the shift button when you upload the programm

[i cant try it out, because i have just bought an attiny but i have no time to check it out]

good luck! :wink:

First you will have to install the specific files for the tiny, called a core.

I can recommend this one:

https://code.google.com/p/arduino-tiny/

As you see there is a version for either IDE version 1.0x or 1.5.x
Follow the read.me file when you install the files

Then you just follow these steps:

http://www.ernstc.dk/arduino/attiny85.html

I've been following the instructions from high-low tech, which are basically the same, the only thing I haven't done is try overriding by using "-F" because I have no idea what that means, and my google searches have not been very helpful. Do you guys know how to use "-F" to override the check?

Wrong microcontroller found.

This tells you that you have chosen the wrong board, the -F won't help.

I wonder if you are following the right steps, and all of them ?.

  1. Upload the ArduinoISP to the Arduino dont't connect the capacitor yet.
    2 Connect a 10 µF capacitor from reset to ground on the arduino (negative side to ground)
  2. Open the blink sketch and change pin13 to pin3
  3. select Tools -> board -> Attiny85@1MHZ (leave the serial port as it is)
  4. Select Tools -> Programmer -> Arduino as ISP
  5. Select File -> upload using programmer
  6. Connect a LED with resitor to pin PB3

Now you should have a blinkining Led on your Attiny85

I've just run through those steps again just to be sure I wasn't missing something, and I'm still getting the same error message. Could it be that the problem lies with the ATtiny folder I downloaded from high-low tech?

I downloaded it, unzipped it, took out the folder called "attiny" and put that folder in a folder named "hardware" in my arduino sketch folder, closed the Ardunio development environment, and restarted it. It seemed to work fine. The attiny options appeared under my board menu.

I forgot to mention that I'm using a non polarized 10 uF capacitor. Could that have any effect?

the folder i copied was called attiny45_85 - perhaps you downloaded something else?!

the capacitor should have 10uF. it should be ok, whether it is polarized or not...

btw: why do we need that capacitor? what does it do?