uploading using a serial port

I am having a problem with my serial communication when uploading sketches. I have a ch340 usb to serial converter connected to my atmega328p-pu. The DB9 is connected as

pins 2 and 3 as RX/TX via MAX232
pin 4 as reset via MAX 232 and a 100nF capacitor
pin 5 GND
pins 7 and 8 connected together.

It works fine and I am able to upload to the chip but if I swap the ch340 device for my serial cable from my real serial port it does not work. It gets as far as dropping the reset line so the LED on pin 13 flashes but no upload and I get the avr sync 0x00 error.
I am rather baffled. Any ideas?
Mrs Z

First close the Arduino software. Then, switch your cable. Then restart the Arduino software

Thanks for your reply. I have tried two different cables, both of which work fine for Mr Z. I have tried two different Arduino IDE versions (1.5.2 and 1.4).
I do not think it is the Arduino as its works with the ch340 and I get data corruption if I do a loop back test. It gets worse as I increase the baud rate. 300 baud is just about OK but I need 115200 to upload.
Mrs Z