Uploading W/ramps 1.4 installed won't upload sketch (solved) kinda

I am running out of options I have read so many posts about this but havn't come up with an answer. Its probably right in front of me.

Video 1. Part 1. 3d Printer problem with ramps board 1.4 uploading sketch - YouTube

Video 2. Part 2. 3d Printer problem with ramps board 1.4 uploading sketch - YouTube

What I've done so far

  1. Arduino will not upload a sketch if ramps 1.4 is installed.
  2. Remove ramps and upload sketch works fine changes take effect.
  3. Use arduino IDE and compiles fine but, times out during upload if the ramps is mounted.(fine if removed).
  4. I have tried removing everything including stepper drivers.
  5. I have tried with and without power supply installed on ramps.
  6. When I have ramps board on I can connect in Repetier but, if I try to move stuff (via repetier host) I have to manually send the (fake OK) recieved button for it to actually move and this is not consistent.
  7. I have tried uploading a print file onto an SD card and try to just print that way without the usb plugged in. The printer will go up hit the limit home switch then it freaks out.
  8. I can use the LCD to manually hit the home all and it will go up and touch the limit switches and then back off. Like its suposed to.
  9. I have used the sample sketch in the arduino IDE to (clear eeprom) settings then re-downloaded my firmware and re-installed it after a clean eeprom clear. I have tried this in about 20 different combinations.
  10. A friend of mine uploaded the firmware first on my board and everyhing seemed fine. I was going back and tuning my lengths better on my printer and this started.

I have come to the conclusion I have something wrong with my ramps board but don't know what to look for. I don't see any burnt traces or smell anything funny. I know its not the stepper drivers because I've removed them and I get the same results. I know its not any of my motors or limit switches because I have tried disconnecting them completely. I don't think its the software due to the fact that Pronter Face, Repetier Host, Arduino IDE all do the same thing.

I have also read I don't know how many posts about people having upload issues. I have double checked triple check ports and baud rates and they seem to be solid in my eyes (I "think" this because I can upload and verify that my changes took place).

Ramps 1.4
Official Arduino Mega 2560 R3

Thank you for your help in advance.

I think I found the problem. Someone said I'm having a problem with my TX and RX pin. They said to bend them to the side on the ramps board or remove them. I have removed them and all said problems have gone.

I can upload sketches while everything is installed, use and respond to serial monitor, repetier host is updating at the bottom and the firmware is populating.

Hopefully this helps some else