Uploads failing on previously-working board

My Arduino Uno r3 board has recently stopped accepting uploads of new sketches. When I try to upload, nothing flashes on the board, and the following output is returned:

avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files\Arduino\hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : \\.\COM14
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Recv: 
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

I’ve tried doing a loopback test by putting a jumper between RESET and GND, and another between digital pins 1 and 2, but I do not get an echo back.

I’ve tried the following to resolve the issue - all unsuccesfully so far.
Checked that COM port selected was correct, then tried using a com port with number <10.
Disconnected eveything but the USB cable from the board.
Pressed reset button at various points before and during the compilation/upload process.
Tried a different USB cable.
Tried uploading from a different PC.
Tried replacing the ATMega chip with a different (brand new) ATMega chip with bootloader already installed.

Other notes:

  1. I’ve tried this on a Windows Vista PC, as well as a PC running Windows 7.
  2. The reset button and bootloader appear to be working - if I press this, the pin 13 LED flashes a few times, goes off for about 2 seconds, then comes back on.
  3. The program last successfully uploaded to the board still runs perfectly.

Can anyone suggest what else I could try?

Thanks,
James

See if a different baudrate helps

/baudrate = 19200 (or 9600)

Thanks srimadh. Would I need to get hold of a programmer to update the bootloader in order to change the upload baud rate?

Is it possible that the USB to serial converter was fried somehow? Could I get a stand-alone usb/serial converter and plug this directly into the TX/RX pins?

Or would I be better off just getting a new board? :-/

I found a post about re-flashing the ATMEGA16U2 (https://www.virtuabotix.com/how-to-cure-sudden-uno-death-syndrome/), and was holding thumbs that this was going to resolve my problem. Unfortunately, I couldn't even get the board to go into DFU mode using either this technique, or another one I found elsewhere on the Internet. Does this imply that my ATMEGA16U2 is cooked?

Is there any other way I can upload new sketches to the board?