USB A port died

I have just received an Arduino Yun rev. 2 as a replacement for my original one. The first board was sent back because it would not power up when plugged into a PC with its USB A port. It initally worked for a minute or two, but then stopped. The board still worked fine when powered from an old cellphone charger on its microusb port.

I ran the new board initially using power on its microusb port and it worked fine. Then I plugged its USB A port onto a USB A port onto my Windows 7 PC and it kept working. But I was unable to see any new USB device on the PC. Then I turned off the power on the microusb port, and it kept working, obviously getting power from the USB A port. But still I could not find any new USB device on the PC. So I unplugged it from the PC USB port and plugged it into an older PC running Ubuntu 16.04, using the USB A port. For a minute or so it powered up and seemed to be initialising normally, so I went to my Windows PC and connected via SSH to the Ubuntu box and ran lsusb. There was again no new USB device listed. So I went back to the Yun and by the time I got there, the Yun no longer had power (its LEDs were all off), and I noticed a smell around the Yun typical of a blown capacitor. So it looks like the USB A port has died. I unlugged the USB A port and plugged in power on the microusb port, and the board again worked fine.

I am guessing that the same thing happened to the original board - it worked for a short while using power from the USB A port, then that port died. The second board worked longer from its USB A port, but then that also died. So does anyone have any idea why this should be happening? The USB A ports on my PCs are nothing special, and are working fine with other devices. I did have to buy a USB A to USB A cable to plug the Yun rev. 2 in, but that should not be able to cause a problem like this, should it? Has anyone else had a problem like this?

In case it makes any difference, both the Yun rev. 2 boards were bought from Element14.

Then I plugged its USB A port onto a USB A port onto my Windows 7 PC

Just curious, why did you do that? The USB-A is a USB host port, just like the USB-A ports on your computer. It's there so you can use USB devices (a thumb drive for example) with the Atheros AR9331. It's not going to create a device on your computer. I'm no expert on the Yun, but I wouldn't be at all confident that it's safe to power the Yun through it.

I did have to buy a USB A to USB A cable

When you have to buy some crazy rare USB cable just to connect two things together, it's probably a bad idea.

OK, so it is a host USB port. That explains my problem. I went and took a look at the ports on the Yun rev. 2 schematic in Eagle and sure enough, the microusb port is the one that connects to the ATmega32U4 D+ and D- pins. So that is what I need to connect to my PC. Fortunately, I have no need of a USB host port, so having killed it will not affect my use of the board. Typical beginners problem - the documentation does not actually say which port is which, so I blundered into this.

I agree that the documentation could be better on this subject. For the Due and Zero, there are really nice labeled images followed by some well-written documentation that explains the difference between the two ports:

I don't see anything like that for the Yun. Unfortunately, the Yun is retired now so I don't think there is a lot of motivation for that sort of work on its documentation.

The Yun may be retired, but the Yun rev. 2 was only released a few months ago. So I hope that will spur more interest and better documentation. Having a full OpenWRT router on board opens up all sorts of interesting uses.