USB and my Problem with it i cant describe

So i got an arduino controlling a 5V relay that switches the Power to an USB Port on/off.

The Device that will run via that USB port is an IR controlled LED Strip that is really cheap. Its just an 2m strip with an IR reciever and a USB Plug for its power.

I lost the Remote and common IR signals aren't used by it. However its already set in the Decent Orange i like it to have. So i can just plug/unplug it and it always lights up in that desired color and Brightness.

To let my Arduino with its RTC control when it is being switched ON/OFF i got an Relay and all set up. However here comes that weird Problem i really cant describe better as following.
When i plug it into just the 5V and GND of my Test Circuit (Basically just delivering 5V and GND connected to an USB Female port) and switch it it just lights up Bright White not Orange.... But when i plug it back into the USB Hub (or Phone charger that has a Usb plug) it lights up Orange again.

What is missing that it basically doesnt light up orange?

I mean the USB charger is just delivering Power too... and when i plug in Power and GND of my test circuit its just White.

On those 2 Data lines of USB is nothing happening cause its communication runs over its integrated IR reciever and ICs... or is there some kind of ... "Idle signals" that for some reason the Strip depends on?

So, it behaves differently depending on whether it is powered via 5 volt phone charger or via a PC connected USB cable ?

What Arduino is it ? ATmega32u4 based processors can exhibit this behaviour.
Post the code you are using.

It behaves differently between having it plugged to PC or phone charger. if its connected to my test Circuit then its just White.

The thing is its not even connected to Arduino yet (got a Arduino Uno R3). Theres no code. Just Turning it on and off and later integrating it into the Relay and Arduino stuff.

I just use this thing to test:
Test Supply
5V to Power of Usb
GND to GND of Usb

I tried to connect D+/D- to GRND and with a 15k and 5k resistor between them and GRND once... also tried them while shorted with eachother. No progress.... still white.

i cant get to wrap my head around what the typical Phone charger does what i am missing.

OK. So this LED strip device has a USB plug on it and when plugged directly into a PC it works as you would wish. If you somehow try to feed 5 volts into it, it fails.

Probably there is some driver on the PC which recognises this LED strip device and configures it with some default setting. You may have difficulty emulating that with an Arduino.

But .... how does a Phone charger like this then get it to work (Light up orange). It has its own drivers with IR reciever on it. I cant configure it via its usb otherwise i would do just like my WS2811 10m strip. There must be something with the D+/D- lines of USB but i just dont know what...

(The led Strip is pretty cheap and a bit old. It got no Data or Clock lines like modern Strips but it rather just uses 5v to distribute them over 3 different lines (R, G, B) and adjusts voltage for them... the 4th line is obviously Ground)

OK. So in summary (please correct if I have misunderstood)

  1. Phonecharger: Good (orange)
  2. PC connected: Good (orange)
  3. Your test circuit: Bad (white)

That phone charger can, depending on what it is connected to, deliver 9 volts. A known smart phone can get it to deliver 9 volts, otherwise it delivers 5 volts.
However, a PC USB output will deliver only 5 volts.
Some phone chargers, power banks etc. are completely dumb and only the power connections are made over the USB cable. Not the signal connections.

1 Like

The summary is correct.... annnnd i gotta admit im kind of dumb. I will just switch the supply to the Plug and then use a Usb cable to split the lines and just connect D+/- and the power to the Relay... but it would still interest me why this is happening.

EDIT: In addition i just used above method to plug it into my Splitted up cord... With and without D+/- it lights up orange so there must be something with the voltage... The Strip is 5V btw (Uses USB and is marked on the Strip)