USB Communication trouble on Mac OSX Snow Leopard

Hello,

I'm a new user of Arduino and it's really awesome but I have a huge problem with the usb communication on a mac.

I have Arduino Uno, Arduino Nano and Arduino Mega. When I use the Arduino environment everything works perfectly. I can see value with the serial monitor and upload code on every Arduino Board.

But, if I tried to use pyserial or matlab, even just a cat in the shell (such as cat /dev/tty.usbserial#### or tty.usbmodem), I lose the handle of the program, nothing appears AND I completely lose my USB port i.e. it becomes unusable, for exemple if i plug a mouse, it doesn't work. I have to reboot my computer to fix it.

Yet, I'm just doing Serial.println(0); ...

I tried on a linux and it works find but not on my OSX 10.6.

I don't understand why, I'm trying to fix it for hours and can't find an answer. I hope you will be able to help me.

Thanks

Matthieu

Pitakadu:
I lose the handle of the program,

What program?

Pitakadu:
Yet, I’m just doing Serial.println(0);

When asking questions, it is very important to post the code you are having trouble with. It is impossible to reproduce the issue if you don’t.

Running “stty -a” in the terminal will tell you what baud rate the terminal is setup for, make sure that makes your Arduino.

You can also try using screen, which is what I use, to communicate with my Arduino.

screen /dev/tty.usbmodemXXX <baud_rate>

Note: To exit screen you press CTRL-A followed by CTRL-\
(then answer Y)

Thank you for helping me

All, matlab, python and Terminal. I have to kill them because they freeze.

int value=0;

// the setup routine runs once when you press reset:
void setup() {
  // initialize serial communication at 9600 bits per second:
  Serial.begin(9600);
}

  Serial.println(value);
}

I’m going to try it but I’m not sure it’s the problem because with matlab I specified the baudrate and I had the same trouble.

I would suggest putting SOME kind of delay() in your loop. even 10 or 50 ms could make a huge difference.

The baudrate is 9600 so it's OK.

I tried with 1000ms delay, but it did change the trouble.

With the arduino Uno, it doesn't work but I keep my usb bus usable without reboot.

Another important point: On matlab and python, the freeze appears when I launch the function fopen(port). I suppose that it's the same in the Terminal.

Maybe a problem with the driver ? I saw some post about this.

I had just installed a virtual machine Ubuntu and it works fine. It seems that the problem is really MacOS ...

Pitakadu:
It seems that the problem is really MacOS ...

Given the large number of people who do not have trouble, myself included, this seems unlikely.

Any chance you have a wireless broadband card or any other devices that might emulate modems or serial ports? Ever install software for one of those devices?

I installed PL2303 drivers maybe it's a problem for arduino. I will try to remove them and install last FTDI driver.

EDIT: I removed all usb2serial driver I had i.e. PL2303, FTDI, Profilic.

I installed first FTDI 2.2.16 ==> same problem
Then I installed FTDI 2.2.6 as describe in the how to ==> same problem

I don't understand what happens ... :frowning:

FTDI drivers would not cause a conflict. They create virtual serial port, not virtual modems.

You might make sure lock is setup correctly:
sudo mkdir /var/lock
sudo chmod 777 /var/lock

Thank again for your help

For the arduino Nano, it's a serial port

I did these two commande but still the problem with arduino Uno/nano :frowning: