USB Descriptor Request Failed for Arduino

Hi, I just bought an Arduino Uno and connected it to my Laptop which is running Windows 10 and it is pretty new (~4 months old).
After installing the IDE and drivers I tried uploading the sample code but I got an error:

Arduino: 1.8.4 (Windows 10), Board: “Arduino/Genuino Uno”

Sketch uses 724 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: ser_open(): can’t open device “\.\COM3”: The semaphore timeout period has expired.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

When I checked the device manager, the USB was not recognized and it said “Device Descriptor Request Failed”.
Does anybody have any idea on how to solve this problem?
Thanks.

Presume you have tried other USB ports and maybe other cables ?

Also avoid USB 3.0 ports as they can on occasion cause issues with Arduino boards.
If you only have USB 3.0 then most often a POWERED USB 2.0 hub between the port and the board will fix many issues.

Also is it a real Arduino or CLONE ?
If its a clone it may require additional drivers that are not included in the IDE installation.

Also remove any connections to pins 0 & 1 as they may be used for the USB serial connection.