USB device not recognized

Arduino Nano v3 (atmega 328), senior design partner managed to short something out and now the device will not respond to USB. USB powers it on, but Mac OSX, Ubuntu 9.10, and Windows XP don't see anything. Windows 7 sees a malfunctioning USB device. I tried reflashing it with the AVR programmer and it still doesn't respond to USB, but now led 13 blinks - because of the reflash OEM program. I even soldered on a new FTDI chip to the board and still the USB will not respond. If anyone has any suggestions, I would be extremely happy - we dont have enough funds left in our senior design budget to purchase a new one >:( but my soldering skills are quite good :D

Its nothing to do with the Atmega chip or reflashing, since the USB device will be recognised even if the ATmega is absent from the board. Beyond that, I can't suggest anything except maybe rechecking and/or redoing the FTDI chip.

It's worth trying a different USB cable. I know it's unlikely to be the culprit but it's a surprisingly common problem and cheap to test.

I also do get the message “USB device not recognized” whenever my Arduino Nano is first powered externally at 5Volt and then USB is connected.
However, if it is first powered by USB , and then externally, it works correctly, even if usb is detached and attached while powered externally.

Is this a known FTDI problem???

I am using Windows Vista, and FTDI driver ftser2k.sys version

Is this a known FTDI problem?


but it could be a Windows Vista, and FTDI driver ftser2k.sys version - problem.

I've re-run the FTDI latest WHQL Certified Virtual COM driver setup program, but it appears to do nothing. Quite right so, because it is already up to date.

Running a "Update driver software" from the device manager also says that the driver is up to date.

My 2009 doesn't have this problem, when powered via the external power input. The power circuitry is also a bit different.

In the schematics I see another difference. The FTDI FT232RL pin 26 (TEST) is grounded on th e2009 and not on the Nano. If the PCB implementation is also different in this respect, I do not know.

Is this TEST pin a possible culprit? Or may there be EEPROM setting differences? (who defines/prescribes/programs these BTW)

Looked into the FTDI FT232R datasheet. On pin 26 TEST it says:

Puts the device into IC test mode. Must be tied to GND for normal operation, otherwise the device will appear to fail.

I measured this pin to be open. I soldered the pin to GND (connect Pin26 to 25), tested it.

Problem solved.

P.S. This is a Arduino Nano V3.0 with ATMEGA328. Now I do wonder why a product in its third revision has such a bug. It is not an unusual use-case to have the device internally powered, and then occasionally connected to the PC, e.g. for a code update.

This has cropped up before