USB host without power - Some electronic help required

Hi everyone,

I have a programmable board with 4 usb host connectors, 3 visible and 2 usb hubs/2 port each (you can enable 1&2 and/or 3&4).

1 port is not providing any energy, as far I can see, there is 1 capacitor and 2 other nearby components used in every usb port.
I wish to know if someone knows anything I can do to debug this problem or has any experience (what can be damaged?)

I discovered that the nearby usb DOES provide power but the board itself reboots if I use that port for a while for example with a usb keyboard.

The board is an eBox 3350MX:

CPU: DM&P Vortex86MX (PMX-1000) @933MHz
[Processor is Pentium I MMX compatible - will run i586 instructions but not i686]


Memory: 512 MB DDR2 RAM
[RAM is soldered on-board and cannot be replaced or upgraded]

VGA Integrated Graphics Chip: RDC Semiconductor M2010 (D-Sub 15-pin)
[64MB separate RAM for GPU]

Ethernet 10/100 Mbps LAN: RDC Semiconductor R6040 (RJ-45 connector)
[Built-in PXE diskless boot function]

USB: 3 ports (2 at the front, 1 at the rear)
[Support USB 1.1 and USB 2.0]

Audio: RDC Semiconductor R3010 High Definition Audio
[Realtek ALC262 Audio Codec - Mic in and Line out]

Storage: 1x SD Slot (Supports SDHC up to 32GB)
[SD Slot is bootable but not hot-swappable]

Dimensions: 95 x 95 x 20 mm
[Includes 4 holes for VESA 75 mounting standard to mount behind LCD monitor]

Power DC +5V @ 2A

A part number or link to this board would be needed before any advice could be offered. At the very least a picture is needed.

The original post has now been modified. Thanks.

Thanks for the answer Grumpy_Mike. I have no clue on what's going on.
The only pictures I have are very low quality pictures from a guy that dissasembled the board.

I discovered a new clue: When I use the nearby usb the board is not stable at all. So this problem should be related to the USB power, the back usb works as expected. Too bad that customs charged me a lot for this x86 board, so getting help from the store will be very hard and expensive.

So does the computer work as it should apart from the USB?
It could just be that the software drivers have not been installed for those ports. Power is only switched on when the port is activated so it could be there is nothing physically wrong with it.

so getting help from the store will be very hard and expensive.

I know customs can be very expensive in South America, but I would have thought that they might be able to give email assistance for this. Looking at the photographs it looks like there is unfortunately little you can do in the way of DIY repair, it is all surface mount and the major chips look like BGA devices.

Have you tried plugging it into a powered USB hub to see if it works? Have you tried using a power supply that supplies more amperage than 2A?

Some PCs will not supply adequate power to all the USB ports, esp. simultaneously.

I'm guessing it's USB 2.0 in the rear, and 1.1 in the front.


Yes Mike, everything works but the left usb port. The frontal and the back one produces the pc to freeze sometimes now (I think the failure is expanding now), right now, the sd card with XP was corrupted due the freezes (the registry was corrupted).

If something is wrong with a smd piece I think I can replace it (for example a smd power mosfet) I have replaced some smd components in old arduinos (ftdi) and servos :smiley: but I really don't have idea on what's failing.

One of my questions if someone knows how the usb works, is about: USB ports are powered all the time? can I for example use an external powersource wired to the VCC and GND of the dead usb in the board or there is some kind of relation between usb power and data?

For example I can see a small relation but only for over current signal in an ideal layout exposed here:

So technically, if the usb built in 5V switch is dead I can replace it but I have very little knowledge over electronics. I found this component: AP4435GM datasheet(1/5 Pages) A-POWER | P-CHANNEL ENHANCEMENT MODE POWER MOSFET tracing the power input, can this power mosfet be the guilty?

I am using a usb adapter directly, not a usb port from a computer to energize the board. The board requires at least 500 mA without using the usb ports built in (2000 mA with 3x500 mA devices connected)

I think all ports are 2.0 because in the bios you can configure the speed, so right now I am using the max speed available.

Thanks again!

Does it reboot if you plug something into the usb port while you are in the bios?
If not, then it's probably the OS drivers. Have you tried booting it within Linux?

Yes, but now when I plug something, it is like when I am using for a while the usb port. It can freeze in the bios or in windows, not a driver issue.

Just a shot in the dark, but if you set the ports to USB 1.1 (or whatever the lowest speed is) in the bios, will it still reboot?

I'm not sure if it's a good idea, but maybe you could splice a USB cable to get the power lines from the one that works. Just to see if it's a power issue.

It probably defeats your purposes of getting such a small device, but you could use a powered USB hub to work off your power supply to get more USB ports. I think you can get up to 4 sometimes with a passive hub.