USB no power to UNO, no COM6

I am very new at this and things have been working great and now suddenly when I plug the USB into the UNO the On LED does not go on and when I go to Device Manager there is no Arduino listed in the COM ports. I have been using COM6 but now there is no such COM. I tried re-installing the driver, but no luck. The barrel plug lights up the On LED just fine from 9v battery.

It means that no power is supplied to your arduino. Try using a wall-wart.

Your Arduino is not getting power. Have you tried a different USB device on that port? Have you tried a different cable? Do you have anything else connected to the Arduino? A short circuit between +5V and Ground would cause the built-in self resetting fuse to immediately shut down power.

Remove anything attached to your arduino and try again on the same USB port and then try different USB port, and then different computer. Most computers can install arduino's driver automatically without admin's password so even a library computer could be used.