USB port in Arduino IDE with RTC sleep mode

Hi. I am using an MKR1000 to send temperature and humidity data to ThingsSpeak. Since I would like to run on battery, I started to play with the rtc.stadbyMode of the RTCzero library.

While it runs like a charm, I can no longer upload using the IDE. The board is simply not recognized by Windows (actually it does not even play de USB plugged in sound).
I tried double clicking the reset button on the board, but so far the same issue appears.

Thanks for your help.

The double tap is two QUICK taps.

Hope you have more luck than me. Have been doing same thing as you with an MKR but mine locks up at random...

I tried the QUICK double tap, before and after hitting the Upload button in the IDE: both didn't do anything. :frowning: Same with single tap. Would you have any other idea ?
Thank you!!

Disconnect anything you have and try the blink example.

Don't forget to change the pin number to suit the MKR led pin (6).

Not 100% sure but check the MKR old section as I seem to recall an issue with RTC or a similar library bricking a board.

Actually removing all connected devices helped. It is now recognized and I could upload the blink sketch after the double tap on the reset button.
Thanks a lot !!!

Glad you are running again at least.

All I can suggest is double check your pins when re-connect your hardware and make sure they don't conflict with anything the MKR may need in regards serial pins.

Maybe also try the RTCZERO on its own without any hardware too.
Or maybe another RTC library ?

And once again do check the older MKR section (marked as read only) as there are some great posts by those who tested this thing. Also take a wander across to the website as they have quite a bit of MKR projects you may be able to get extra info from.