Usb_serial generic read bulk callback - urb stopped: -32

I am trying to connect two Original Arduino Nano to RaspberryPi 4 using the USB.

The Arduinos are powered by the same RPi USB and the RPi is connected to a 5V wall power adapter.

The code sends a value from 0 to 254 through USB Serial connection. Works fine for a couple of hours and then completely stops with no reason or error in the terminal window.

When I run dmesg -T it shows me the error:

ftdi_sio ttyUSB0: usb_serial_generic_read_bulk_callback - urb stopped: -32

I already:

  • Checked connections to see that cables are firmly plugged.
  • Tried to reduce the dwc_otg.speed=1 but no difference

I am using 9600 Baud rate and in the RPi I am running this code from Jim Paris: Jim Paris - git.jim.sh

I have seen a lot of people with similar issues but apparently they have solved with one of the options I have already tried.

I am open to try any other suggestions to see if I can make this work 24/7.

Thanks in advance for all the help you could provide

Two things to check:

  • current consumption
  • fake FTDI chip