USB stopped working

Hi. Im using a Duemilanove and it suddently crashed. I unplugged and plugged it again and now windows says the usb device could not be recognized or just ignores it. I cant even remove it from the device manager, as its not there anymore. So is my FTDI chip broken? how? why? so soon? i’ve been using it for two days and havn’t been connecting anything weird.

Could be the FTDI chip is broken.

Could be you need to reboot.

Could be you have a bad USB cable.

Let's elaborate more on "connecting anything weird". What have you been connecting?

True. I wrote that too fast.

About "connecting anything weird", Im using a 5DOF IMU from sparkfun. Im using 5 analogs and a 3.3 vref and it has been working great for a day. I havnt touched any of the cables, or added anything new. I though the most probable cause of FTDI chip dying is shorting some of the pins or giving it too much current. What I meant was that im not working with loose cables or anything that could touch wrong pins.

I tried rebooting windows. Then I went on linux and checked dmesg and lsusb and the thing (FTDI) just doesn't say a word. I changed the USB cable. Nothing.

Out of desperation I started touching the board with my fingers and bending it (just a tiny bit, you know.. xD) and Surprise!! linux sees it for a second, then it disconnects. Now it works intermitently... it may work for 10 minutes, sending data over the serial port intensely and then just stop working again. I do the little bending trick and the tx and rx leds start lighting again.

This is a new arduino (2 days old), so im not sure how to take this. There are no bad connections as far as I can see, although the bending thing clearly says otherwise.

So Im sorry for writing that fast, I should have tried some more before. Anybody has had similar issues with an arduino or FTDI chips? Thank you in advance!