Use Arduino with the L293E DC Motor Driver

Hey,

I'm getting beat up by this L293E IC. I'm not sure this is the right place to post this doubt, since I gave up using the Arduino in the circuit until I sort out what is wrong with it.

Here is the deal: I've set up the L293E pretty much like the application notes suggests (I would post a link and pictures, but seems like I can't because this is my first post here). Nonetheless, I'm falling to get the motor to run... :/

Basically there is a 12v power source regulated to 5v. The 12v goes to the 'motor power input' (pin 10) as it is, the 5v goes to the 'enable pin' (pin 1) and the 'ic pin' (pin 20) and the GND goes to pin 5, 6, 15, 16; then the 'input 1' (pin 2) and 'input 2' (pin 9) are connected respectively to LOW (GND) and HIGH (5v).

Here is the thing: when I measure the output pins (3 and 8) with the voltmeter I get 11v. Theoretically there is no problem, that is what I want. But when I connect the DC Motor to the output pins it doesn't run, and I measure 0v between its terminals.

Please, I need a light on this mater... anyone?

Hey,

It is a plastic DIP. It's the L293E (16+2+2). It has 20 pins. I got the datasheet from here: http://www.datasheetcatalog.com/datasheets_pdf/L/2/9/3/L293E.shtml

I've tried this and didn't make any difference. :-/

Problem solved. The wires I was using to connect the 'sense' pins to GND wasn't working properly. :-/

Thanks anyway.