Using an UNO to load a hex file on the Sparkfun RGB Matrix Board

my hardware is a Macbook Air, running Yosemite, the Arduino IDE 1.6.0



I have a Sparkfun LED Matrix that needs updated firmware. The firmware is there on the page, but it’s a hex file I think. I am very familiar with Arduino sketches, and I’ve even used an UNO to burn the boot loader on Atmega328P’s and Atmega328P-AU chips. I would know how to connect my UNO to the ICSP and load a sketch to this, as I see it has an Atmega328P-AU chip, but I don’t know what I’m looking at when I open the firmware file. Here is the firmware folder. Can someone tell me how to get a sketch out of this or how to use my UNO to load it onto the matrix board? thanks so much.

I couldn't get anything to work on the matrix, so I tried another one I have that does work. I was able to use my UNO and connect to the MOSI,MISO,SCK,& Reset pins on this matrix board, and then I burnt the boot loader to it. It verified correctly as the Arduino Pro 5V 16Mz and loaded the bootloader onto it. But now I need to load the firmware on this one. I tried just sending a simple blink sketch to it, using the same ICSP pins that I burnt the boot loader on it with, but it will never take a sketch using the Arduino as ISP. I tried burning the boot loader again and that aways works. under 'Programmer', I selected Arduino as ISP. I'm not sure why I can't load something onto it. I found one article saying how to turn on verbose output-I copied the command lines from the Arduino IDE that it gave when I loaded the boot loader, and pasted that into the terminal window of my Mac and it all executed properly. But when I try to load a hex file that way, it doesn't work either. If it will take the bootloader, why won't it take a sketch?

Now I have 2 matrix backpacks that don't work. :(

ps. when I was trying to load a sketch over 'arduino as ISP' to it, I once switched the setting for the Atmega processor to 168 instead of 328, and it gave me the error of incorrect chip signature. But when I put it back to what it should be, 328, it didn't give me that message, it would just give me the 'programmer not responding' error 10 times. I just don't understand why it would let me burn that bootloader, but not load a sketch or hex file. My wiring setup has to be correct since the boot loader works, right? Sorry to be long winded, but I am anxious to know if I can resurrect these things.

The RGBMatrix board uses an atmega328p avr mcu, with built in firmware. But it’s not an Arduino. Don’t treat it as one. You do not burn bootloader to it or load sketches to it. It does not run on it’s own. You need to control it with a separate Arduino.

The problem may be that if you tried to burn bootloader to it, it may have the wrong fuse bits now.
Don’t know what would be the recommended fuse bits for the RGBMatrix board.

You should just load the example sketch to your Uno, then connect up the SPI connections to the RGBMatrix board. Then let your Arduino control the RGBMatrix.
RGBMatrix_Example.jpg

I understand all that. I'm trying to load a firmware on it though. With no luck, I experimented by burning the Arduino bootloader on it, which worked. So that means my Arduino as ISP is wired up correctly. But it won't let me load a simple sketch to it with the same wiring. I choose 'Arduino as ISP' so shouldn't I be able to load a sketch with the same wiring setup that burns the bootloader successfully?

Thanks! I didn't realize you had to use 'file/upload using programmer'. I thought if i selected 'arduino as ISP' it would automatically do that. Thanks again!