Using analog sensor TMP36 on a breadboard

Good day!

I'm playing with analog sensor TMP36 (http://www.ladyada.net/learn/sensors/tmp36.html). It is very easy to use, voltage on it's central pin is proportional to the temperature, for example for 25C it should be 0,750V (0,5V is 0C, and step is 0,010V per 1C).

I use it with Arduino on a breadboard, which is powered and connected to PC via spare Arduino board without a ATmega chip.

Here are test cases:

  1. I connect sensor directly to +5V and GND pins of Arduino board: voltage beetween sensor's GND and 2nd pin is about 0,750V (around +25C, the same my wall thermometer), between GND and +5V around 5V. I can connect GND to GND power rail on my breadboard -- it works

  2. I connect +5V pin of a sensor to my power rail on a breadboard (which is directly connected to +5V pin of Arduino), GND can be connected to GND rail on a breadboard or directly to Arduino - it doesn't matter. And now I get only 0,150V. The power (beetween GND and Vcc pins of TMP36) is still +5V as in previous test.

What can interfere with sensor? Will putting capacitor helps (image from datasheet below)?

Thanks in advance!

As far as I can tell the source of the problem is MCU on the breadboard itself. When ATmega8 is in the sleep mode the sensor's output voltage is correct, when ATmega8 is working -- it is wrong. I should try capacitors as stated in datasheet.

I should try capacitors as stated in datasheet.

Always a good idea but probably not the source of your problem.

I can't spot the difference between the two cases but almost certainly when it is not working you have not got a proper power or ground.

Thanks for the reply!

I've tried capacitors (both) -- still no luck. When ATmega chip on a breadboard is on -- the voltage on sensor is wrong, when it is in a sleep mode -- sensor works ok.

The ATmega8 use internal osc (with proper fuses and bootloader) -- in case this is relevant. On the same breadboard also 16x2 LCD is installed -- I've tried to remove it. Digital sensor DS18B20 works ok with this setup (I've tested without it).

Is there any way to check what's wrong with power? I measure voltage between GND and Vc legs of sensor -- it is always +5V (when readings are correct it is 4,99 and when not 4,97). What I can check?

Thanks!