Using Arduino 1.0.6 and 1.6.4 at the same time?

Hello,

I have gotten a 3D printer, but it seems like marlin needs the 1.0.6 version of the IDE while i'd like to use the newest version for all other projects i'm working on.

Is there a way to install both versions of the software on my computer, other than creating a virtual PC?

Thanks.

I did try using Google, it's as if no one has run into this problem before??

Yes. I run 022, 1.06 and 1.6.4 on the same machine with no problem

how did you do it? when I download the program, it says that the previous version needs to be removed...

Qdeathstar: how did you do it? when I download the program, it says that the previous version needs to be removed...

Which OS? You can maintain multiple versions of Arduino IDE in any major OS but I'm not willing to type up all three solutions. ;)

win10

Download zip file and unzip it. Download another zip file of different version and unzip. I recommend uninstalling the installed version first.

Indeed, just use the zip downloads. They don't install, the just run.

But maybe a better question, why does the printer not work? Do you get an error? I bet it's an easy fix to make it run with 1.6.4 ;) (And, yeay, I like 1.6.4 better as well :D )