Using Arduino USB board with Linux CDK4AVR

Just curious if anyone has tried to use the Arduino USB board with Linux CDK4AVR series of software tools, as they work really well together. Much easier to install than manually searching across the World for the pieces/parts to do it that will compile successfully and play together.

The incentive I have is the Arduino Java software for Linux does nothing except allow surfing the directories. And it doesn't even show files, only directories. There are much better tools for directory/file surfing built into Linux. I can use the Windoze version of Arduino as it works, but don't like having to tie up a computer with Windoze just for occasional compiling.

I want to use the Arduino hardware configuration through the USB, not have to resort to the ICSP jack/method (which I would have to make an adapter for, as the serial dongle has 10 pins, and the board has 6). And parallel programming is not practical using today's laptop configurations, which don't come with parallel ports, and most not even serial ports.

Any input/ideas?

I believe it's asking you to select a default directory for your Arduino sketches. Did you try selecting one and hitting "okay" (or whatever)?

Not for that specific purpose but I did attempt to select many directories using the "open" button. These are the indications I get:

  • The first screen after typing, "./arduino" is a GUI titled OPEN. This is where I attempt to select a directory. I tried clicking on both the directory, which allows me to move around, and by clicking on the "Open" button. This is the result of the "Open" button click which dumps me back in the terminal:

Experimental: JNI_OnLoad called. Experimental: JNI_OnLoad called.

Stable Library

Native lib Version = RXTX-2.1-7 Java lib Version = RXTX-2.1-7 check_group_uucp(): error testing lock file creation Error details:Permission deniedcheck_lock_status: No permission to create lock file. please see: How can I use Lock Files with rxtx? in INSTALL Exception in thread "main"

And that's the end. There is no INSTALL file in the *0007 tgz file.

Hmm... try making sure the directories /var/lock and /var/spool/lock exist and are writable by the user that you're running Arduino as. What distribution of Linux are you running?

I am pretty sure /var/lock and /var/spool/lock exist. I am also pretty sure I cannot write them as a normal user. I don’t recall for sure, but seems I have also tried to run the binary arduino as root, with the same results. I can try again to know for sure.

The normal user (me) is a member of the uucp group, so access to ports is not an issue, even though the error above might suggest that.

I am using 32-bit Fedora Core 6 on a laptop. I have tried arduino on another 64-bit FC6 box with the same results. I do have the gij installed (GNU java) but haven’t been able to discover if that includes all the classes I need, or may need. I don’t know where the java classes need to be.

I tried last night to build from svn, which took forever, but got a whole new set of errors, but I am not at home, so don’t have the output.

Since it seems to be a problem with RXTX, you might try deleting the one that comes with Arduino ( and RXTX.jar I think), and installing the RXTX provided by your distribution, if there is one.