Using iMac, problem with PORT selection when trying to uploading sketch to board

2021-06-29T14:00:00Z

Dick here, I know nothing!
I am new to the electronics world.
Trying to upload a sketch to Arduino Nano. I am making a pneumatic power hammer and the Arduino drives the solenoids that regulate the hammer strokes.
I am using an iMac
The Arduino looks ok, one red led on and one led blinking.
The Arduino is not wired to any circuit yet.
Thanks...

The ERROR massage and the SKETCH are attached. And the wiring DIA, I think!

Error message

Arduino: 1.8.15 (Mac OS X), Board: "Arduino Nano, ATmega328P"

/Applications/Arduino.app/Contents/Java/arduino-builder -dump-prefs -logger=machine -hardware /Applications/Arduino.app/Contents/Java/hardware -tools /Applications/Arduino.app/Contents/Java/tools-builder -tools /Applications/Arduino.app/Contents/Java/hardware/tools/avr -built-in-libraries /Applications/Arduino.app/Contents/Java/libraries -libraries /Users/dick/Documents/Arduino/libraries -fqbn=arduino:avr:nano:cpu=atmega328 -vid-pid=0000_0000 -ide-version=10815 -build-path /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701 -warnings=none -build-cache /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_cache_648863 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.avrdude.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.arduinoOTA.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.arduinoOTA-1.3.0.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -verbose /Volumes/WD 8TB Images-1/Images 1.1/Studio8 Projects/Workshop/Power Hammer Drawings/Power_hammer_Sketch/Power_hammer_Sketch.ino
/Applications/Arduino.app/Contents/Java/arduino-builder -compile -logger=machine -hardware /Applications/Arduino.app/Contents/Java/hardware -tools /Applications/Arduino.app/Contents/Java/tools-builder -tools /Applications/Arduino.app/Contents/Java/hardware/tools/avr -built-in-libraries /Applications/Arduino.app/Contents/Java/libraries -libraries /Users/dick/Documents/Arduino/libraries -fqbn=arduino:avr:nano:cpu=atmega328 -vid-pid=0000_0000 -ide-version=10815 -build-path /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701 -warnings=none -build-cache /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_cache_648863 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.avr-gcc.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.avrdude.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.arduinoOTA.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -prefs=runtime.tools.arduinoOTA-1.3.0.path=/Applications/Arduino.app/Contents/Java/hardware/tools/avr -verbose /Volumes/WD 8TB Images-1/Images 1.1/Studio8 Projects/Workshop/Power Hammer Drawings/Power_hammer_Sketch/Power_hammer_Sketch.ino
Using board 'nano' from platform in folder: /Applications/Arduino.app/Contents/Java/hardware/arduino/avr
Using core 'arduino' from platform in folder: /Applications/Arduino.app/Contents/Java/hardware/arduino/avr
Detecting libraries used...
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10815 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/variants/eightanaloginputs /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/sketch/Power_hammer_Sketch.ino.cpp -o /dev/null
Generating function prototypes...
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10815 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/variants/eightanaloginputs /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/sketch/Power_hammer_Sketch.ino.cpp -o /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/preproc/ctags_target_for_gcc_minus_e.cpp
/Applications/Arduino.app/Contents/Java/tools-builder/ctags/5.8-arduino11/ctags -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/preproc/ctags_target_for_gcc_minus_e.cpp
Compiling sketch...
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-g++ -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10815 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/cores/arduino -I/Applications/Arduino.app/Contents/Java/hardware/arduino/avr/variants/eightanaloginputs /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/sketch/Power_hammer_Sketch.ino.cpp -o /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/sketch/Power_hammer_Sketch.ino.cpp.o
Compiling libraries...
Compiling core...
Using precompiled core: /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_cache_648863/core/core_arduino_avr_nano_cpu_atmega328_51f02b7210b938436b779d1c032618e1.a
Linking everything together...
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-gcc -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p -o /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/Power_hammer_Sketch.ino.elf /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/sketch/Power_hammer_Sketch.ino.cpp.o /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/../arduino_cache_648863/core/core_arduino_avr_nano_cpu_atmega328_51f02b7210b938436b779d1c032618e1.a -L/var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701 -lm
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-objcopy -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/Power_hammer_Sketch.ino.elf /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/Power_hammer_Sketch.ino.eep
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-objcopy -O ihex -R .eeprom /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/Power_hammer_Sketch.ino.elf /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/Power_hammer_Sketch.ino.hex
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-size -A /var/folders/sh/rtx1zk5559359hdpt7jfj58w0000gp/T/arduino_build_74701/Power_hammer_Sketch.ino.elf
Sketch uses 2108 bytes (6%) of program storage space. Maximum is 30720 bytes.
Global variables use 184 bytes (8%) of dynamic memory, leaving 1864 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
Problem uploading to board. See Upload – Arduino Help Center for suggestions.


![Wiring Dia|690x490](upload://uRXJla7FeDGvPq5DBpgAWrXsqwK.jpeg)


[code]

int Sol1 = 13; //solonoid 1 (down stroke)
int Sol2 = 12; //solonoid 2 (up stroke)
int Prx = 2; //Proximity sensor for restricted cylinder extention

void setup() {

 Serial.begin(9600);
 pinMode(12, OUTPUT);
 pinMode(13, OUTPUT);
 pinMode(2, INPUT);

}

void loop() {

 if (digitalRead(Prx) == LOW)
 {

   digitalWrite(Sol2, LOW);
   digitalWrite(Sol1, HIGH); //When the Hammer head is engaged with sensor(Prx)Sol1 sends the head up

 }

 if (digitalRead(Prx) == HIGH)
 {
   digitalWrite(Sol1, LOW);
   digitalWrite(Sol2, HIGH); //When the Hammer head is up past the Sensor(Prx) Sol2 sends the head down
   delay(100); //you can adjust the delay of the down stroke here in miliseconds to optimise performance



 }


}
[/code]

First try upload with nothing connected to Nano.
Second try setting the processor to "ATmega328P (Old Bootloader)" in tools menu

And of course ensure the correct port is selected in the menu.

If it’s a clone nano you might need a CH340 driver

I did what you suggested but same result.
Error Problem uploading to port

Dickc

That does not look like your arduino.
Is it a clone ?

Thanks,
Which IS the correct port?
How do I know if it is a clone?

Dickc

Did you buy it from the Arduino company ? Does it carry the arduino brand on it?
You might have a ch340 usb interface and need a driver on your mac for thé port to appear

I bought from Jaycar It has NANO V3.0 on it.
How do I check the usb interface I have?

Do you have a link?

Ahhh, what's a link??

I meant a web link to where you purchased the board to see the specifications

OK Thanks, I have attached a screen shot of Arduino description…

Ok so it should be recognized by your Mac when you plug it in.
Have you tried another cable ?

Thanks, I am going to get another cable today….To be continued
Cheers

Same error message with new cable. iMac talks to the Arduino ok I think.
The sketch can be verified but problem occurs when attempting to upload.

I don’t think it can talk to the arduino. The port you showed is for Bluetooth.

Can you launch the IDE without the Arduino plugged in and check what you see in the Serial port menu.

Then plug the arduino in and check what you see again.

Is there a difference?

Thanks, not sure what and IDE is but I did this, see screen shot.
I think it's, as you suggest, the port selection that is the problem.
I am not given an option to select any other port.

The IDE is the Arduino Integrated Development Environment (so what you are showing).

if nothing appears when you plug your arduino into your Mac, then indeed it's an issue. the Arduino is not detected. Your Mac does not see anything connected. (you could check running the System report and check on USB)

this is what the same menu shows on my Mac when connecting and Arduino Uno
image

are you plugging it in through an USB hub or directly? are you 100% sure the cable you use is not just a charging cable, but really a data cable?

Hello JML, I have switched from my iMac to my MacBook pro but no luck. I have a new USB lead and screen shot of USB system report and PORT options are attached.
There is no indication in FINDER that the arduino Nano is connected!!! Although the lights on the nano board come on, one constant and one blinking.



Regards
Dick

I assume you tried with nothing connected to the Arduino but the USB cable.

can you get your hands on another arduino?