UspASP killed Nano v3.0?

My problem is the following. Something obviously went wrong. I left my mini usb cable at a friend's place, and have no other. I was working on a small sketch, and figured, is will use my UsbASP tp program my nano. It's the ebay variant, with outdated firmware. I wasn't using it lately, so never bothered to update the firmware. Beforehand I solved the sck period issue, with the connection of the jumper that slows down the programmer to 8mhz, wich worked for programming ATTinys on a breadboard. Now after using it to program my Nano - a chinese clone with the ch340g usb chip - I had an unpleasant surprise. The Nano's onboard usb stopped working. At least in IDE. Avrdude gives me error messages, and will not upload the sketch.

message: "avrdude: stk500_getsync(): not in sync: resp=0x00"

Is this solveable? I can program the nano with UsbASP just fine, but not via cable, wich is annoying. The cable now works only as a power lead.

The “USBasp” is the name! :slight_smile: Once you’ve used ISP for programming the chip the bootloader is removed and it cause unable to program via serial. In other words you’ve used USBasp for programming so bootlader was removed. No bootloader - no programming via USB. You have to burn the bootloader back via USBasp for recovery.

:) FACEPALM! Thanks! My mistake... Managed to get the bootloader back. It's working all right again. Since then I managed to update the USBasp firmware aswell.