UTFT + 2.4 Itead Touch Shield Does not display anything

Hello everyone,
We have got Mega 2560 and Itead 2.4 Touch Shield (8 bit).
So far we have tried these;
Connecting via jumpers, DB8-DB15 to the pins that has been described in the PDF in UTFT, and RS, WR, CS, REST to all possible pins (almost literally ever variaton). We have tried almost every written code in the first 2-3 pages of google for TFT's, touch shields, etc. We have plugged the shield on a leonardo directly, and mega directly and tried the matching codes for plugging it directly but again so far not a single output except the "somewhat white" screen that also can be seen when the voltage input is plugged only.

What do you suggest? Where could we have been doing wrong? Is there any examples of connection between MEGA2560 - 2.4 TFT Touch Shield? Is there any specific code for MEGA2560 - 2.4 TFT Touch Shield? Thanks.

Here is an working example of using an 2.8 TFT Itead. and Arduino MEGA2560
First steps in the article deals with configuration. 2.8 and 2.4 are similar(same controller).

Hint: in file ...\libraries\UTFT\hardware\avr\HW_AVR_defines.h must uncomment line
but it is better to read entire article ...