Validating license failed: OAuth2 request failed: Service responded with error

Trying to upload and save via Arduino Editor using my son's account on Chromebook yields the following error message: "Validating license failed: OAuth2 request failed: Service responded with error: 'Service has been disabled for this account.'"

Notably, I don't get this error when using my own account, so presumably it has something to do with settings in Google Family Link. I have tried whitelisting create.arduino.cc (for fun) and googleapis.com (because another post referenced it with a similar OAuth2 error message) but no luck. Any ideas? Thanks in advance.

Pushed the issue upstairs.

You can also aske directly using the SUPPORT FORM.

Bob.

I also have this problem - same error message and same behaviour. Chromebook works fine with Web Editor and Arduino Uno when logged in using an adult Google account, but not when using a supervised junior Google account.

Is there a fix?

Many thanks.

@trustynuthatch475

There is an age limit (13) for use of the web side of things.
Unfortunately these are mandated in Europe so no real way around it.

Bob.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.