Verification error; content mismatch

Hey!
I have an arduino uno R3 clone called Funduino, worked fine for couple months but now i get this error:

avrdude: verification error, first mismatch at byte 0x0000
0x0c != 0x62
avrdude: verification error; content mismatch

The on green led and the led on pin 13 are constantly on.
Anyone knows anything about this?
Tried upgrading USB Firmware with FLIP like this ARDUINO- Upgrading USB FIRMWARE using FLIP - YouTube
but the error remains
Thanks!

It means that the computer has told the boot loader to write a specific byte value and when it reads it back it is not the same. This means the flash memory in the processor chip is now bad.
You need to replace the processor chip.

You mean change the ATMegaU16 ATMega328p-pu entirely?
Flashing the bootloader won't fix the problem?
Thanks!

You mean change the ATMega328p-pu entirely?

Yes well you can’t change part of it can you.

Flashing the bootloader won’t fix the problem?

Well you could try, it would cost you nothing, but it is unlikely to be the problem.

Can this be done with another Arduino?

Cono:
Can this be done with another Arduino?

Yes.

Im guessing this is exactly what i need

Thanks a lot for the help

Well not exactly. There are parts there you don't need and the 328 chip has not got a boot loader in. What you exactly need is something like this:-