Very strange caching issue (solved)

Edit: Ugh, nevermind, was all user error.


I have a file called "relay_stuff.h" that contains all the routines that pertain to using relays in my project.

When I open the Arduino IDE that file opens as a folder tab in the IDE.

I'm including it like this:

#include "relay_stuff.h";

That's been working well for weeks, but suddenly it's using a very old version of the file. I'm using Windows and I cleared what I think is the cache folder (C:\Users[username]\AppData\Local\Temp) and then restarted the IDE, but still it's using the old verison.

I also tried renaming the included file (renamed "relay_stuff.h" to "relay_stuff2.h") and restarted the IDE, but no luck.

I don't imagine anyone has any tips?

Edited to add: updated to the most recent release version of the IDE (1.8.13) and still having the problem.

One thing I thought might be relevant is that it's a progmem that's getting cached? I'm not sure if the rest is being cached. But the fact that the caching issue happens even with new unflashed Arduinos tells me it isn't related to progmem.