vidor 4000

I am new at this. I have spent considerable time trying to get the vidor board to work. Sometimes it hangs up on the uploading and i have gotten various errors though not consistent. Have reloaded all the libraries. Very frustrating, saying no jtag interface configured, No Bootloader, or very rarely it appears to work. That is loading Blink program. Certainly not worth the 60 bucks i gave amazon. Do I have the a bad board or am i trying to to do something i'm just not capable of?


I am sad to know that this new board model is being problematic :frowning:

This board is a little advanced, if you do not have prior knowledge of the most basic boards, such as the Arduino UNO, it may be interesting to know that just like any other electronic device, this board may also present some problem, which is normal in any board of development.

One of the most common problems is the breaking of the USB cable,

So, have you done any diagnosis to find the solution to the problem?

Some questions may help:

  • Have you tried using another cable?

  • Have you tried using another computer?

At this point I believe you have already accessed the product presentation page:

Getting Started with the Arduino MKR Vidor 4000

I found a video that talks about this board, and the first problem that appeared was with the USB cable, you can see here:

Arduino MKR VIDOR 4000 Hands-On | AddOhms Live #11 [25m:10s]

Have you updated the SAMD bootloader as per

Hi cvpacifier, as I didn't see more comments from you I hope you managed to make Vidor work reliably. I'm sorry you didn't have a great out of the box experience but I hope you understand this is a very young product and for sure a complex one on which we're trying to simplify things.
If you didn't manage to get it working please let us know which exactly are the issues you're facing now and we'll try to help you get through.


Good day people. I have been working too hard and recently got some spare time and a new laptop. I was getting compile errors some of them generated by file name issues. With the new laptop (lenovo legion y7000) was getting similar behavior with the device unable to find certain support files during compilation. So i wiped everything clean and started over. Have been able to get board to compile and upload, though sometimes it will fail. I am sure you have heard this before but the frustration one encounters trying to make it function robs you of much of the learning time. I wish to thank you for your comments. I'm sure as i go forward, i will have more of my own. cvPacifier

glad to hear you're making progress. we know we have to work a bit harder on documentation and we're working on it. it just takes a while and since FPGAs involve many changes in what exists so far there are some things that won't work out of the box unless you have the latest versions of the tools.
this as well is something we should document better and i'm taking note of this as probably we need to outline very clearly in the getting started guide which is the minimal version of the tools you're supposed to use.