Vista "Error getting the Arduino data folder.

I recently switched to Vista (from xp) and I installed a fresh copy of the Arduino 0012 IDE.

It am getting an Error (below). I have Tried using the .exe and the run.bat with no avail. Any idea what could be wrong here? :-[

Hi,

Not sure if this will help with your error, but I get better results with Vista if I r-click on the Arduino.exe and select "run as administrator" to launch it.

Nope, that didnt work. :-[

Thanks for the reply though. :)

I'm having this issue too.

Googling the error message leads to this forum as 1 of 3 results.

Am running as admin, and have tried XP compatibility mode. Not sure what to try next.

Appreciate any suggestions or solutions.

Does your username have any non-ASCII characters in it?

No, just a regular name, no special chars, spaces, punctuation or symbols.

I'm having this same problem with 32bit Vista. Tried as admin, in xp mode, and versions 0013 and 0012.

As quickly as I post this I finally figure it out.

Open in your arduino-00## folder, the preferences file in a text editor. Then find the line settings.path.fallback=data, and comment it out. On the line above, uncomment settings.path=data, and make it look like the following:

settings.path=c:\Users*User*\AppData\Local\Arduino

Thanks! It's solved the problem for me.

Awesome, worked here too.

Many thanks.

I'm running 0016 and I get the "Arduino cannot run because it could not create a folder to store your settings".

Strange because it ran fine the first time and when i closed and reopened it it stopped working.

Tried that preference list change, tried XP mode, Admin mode, don't have weird characters in my username. What could be wrong? Thanks