Visual-Studio-Code mit javascript und Arduino verbinden

Hallo zusammen,

leider bin ich doch am verzweifeln
Video geguckt und viel gegooglet leider nicht zum Ziel gekommen.

Ich würde gerne in Visual-Studio-Code mit Javascript das programm für Arduino entwickeln.
Leider sind meistens die wege im internet so unterschiedlich und unverständlich das ich zur lösung komme.

node.js habe ich schon runtergeladen
Welche befehle muss ich nun ausfürhendamit ich zum ziel komme?

asdfer123:
Ich würde gerne in Visual-Studio-Code mit Javascript das programm für Arduino entwickeln.
Leider sind meistens die wege im internet so unterschiedlich und unverständlich das ich zur lösung komme.

Der Arduino kann nicht mit Javascript programmiert werden.

Gruß Tommy

nach der anleitung

(Controlling Arduino with Javascript Using the Johnny Five Library - YouTube)

hier wird johnny-five benutzt.

C:\WINDOWS\system32>npm install johnny-five

@serialport/bindings@8.0.8 install C:\WINDOWS\system32\node_modules@serialport\bindings
prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
prebuild-install WARN install No prebuilt binaries found (target=14.5.0 runtime=node arch=x64 libc= platform=win32)
C:\WINDOWS\system32\node_modules@serialport\bindings>if not defined npm_config_node_gyp (node “C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild )
gyp ERR! find Python
gyp ERR! find Python Python is not set from command line or npm configuration
gyp ERR! find Python Python is not set from environment variable PYTHON
gyp ERR! find Python checking if “python” can be used
gyp ERR! find Python - “python” is not in PATH or produced an error
gyp ERR! find Python checking if “python2” can be used
gyp ERR! find Python - “python2” is not in PATH or produced an error
gyp ERR! find Python checking if “python3” can be used
gyp ERR! find Python - “python3” is not in PATH or produced an error
gyp ERR! find Python checking if the py launcher can be used to find Python 2
gyp ERR! find Python - “py.exe” is not in PATH or produced an error
gyp ERR! find Python checking if Python is C:\Python27\python.exe
gyp ERR! find Python - “C:\Python27\python.exe” could not be run
gyp ERR! find Python checking if Python is C:\Python37\python.exe
gyp ERR! find Python - “C:\Python37\python.exe” could not be run
gyp ERR! find Python
gyp ERR! find Python **********************************************************
gyp ERR! find Python You need to install the latest version of Python.
gyp ERR! find Python Node-gyp should be able to find and use Python. If not,
gyp ERR! find Python you can try one of the following options:
gyp ERR! find Python - Use the switch --python=“C:\Path\To\python.exe”
gyp ERR! find Python (accepted by both node-gyp and npm)
gyp ERR! find Python - Set the environment variable PYTHON
gyp ERR! find Python - Set the npm configuration variable python:
gyp ERR! find Python npm config set python “C:\Path\To\python.exe”
gyp ERR! find Python For more information consult the documentation at:
gyp ERR! find Python GitHub - nodejs/node-gyp: Node.js native addon build tool
gyp ERR! find Python **********************************************************
gyp ERR! find Python
gyp ERR! configure error
gyp ERR! stack Error: Could not find any Python installation to use
gyp ERR! stack at PythonFinder.fail (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\find-python.js:307:47)
gyp ERR! stack at PythonFinder.runChecks (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\find-python.js:136:21)
gyp ERR! stack at PythonFinder. (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\find-python.js:225:16)
gyp ERR! stack at PythonFinder.execFileCallback (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\find-python.js:271:16)
gyp ERR! stack at exithandler (child_process.js:315:5)
gyp ERR! stack at ChildProcess.errorhandler (child_process.js:327:5)
gyp ERR! stack at ChildProcess.emit (events.js:314:20)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:274:12)
gyp ERR! stack at onErrorNT (internal/child_process.js:468:16)
gyp ERR! stack at processTicksAndRejections (internal/process/task_queues.js:80:21)
gyp ERR! System Windows_NT 10.0.19041
gyp ERR! command “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\WINDOWS\system32\node_modules@serialport\bindings
gyp ERR! node -v v14.5.0
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok
npm WARN system32@1.0.0 No description
npm WARN system32@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @serialport/bindings@8.0.8 (node_modules@serialport\bindings):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @serialport/bindings@8.0.8 install: prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

  • johnny-five@2.0.0
    updated 1 package and audited 93 packages in 19.985s
    1 package is looking for funding
    run npm fund for details
    found 0 vulnerabilities

C:\WINDOWS\system32>npm install johnny-five

im video kommen keine fehler warum bekomme ich das nicht installiert?

Tommy56:
Der Arduino kann nicht mit Javascript programmiert werden.

Gruß Tommy

Was mir auffällt:

"gyp ERR! stack Error: Could not find any Python installation to use"

Aktuelle Python version installiert und im Pfad?

Aber laut dem Video muss Pyton garnicht installiert werden.

Das ist das was ich nicht verstehe.

Abgesehen davon ist Python eine programmiersprache programm ??
ich benutze visual studio code

In dem Video siehst Du auch nicht, wie er Windows installiert, trotzdem benutzt er es.
Und ich finde die Fehlermeldung relativ eindeutig:

You need to install the latest version of Python.
Node-gyp should be able to find and use Python. If not,

Microsoft Windows [Version 10.0.18363.900]
(c) 2019 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Windows\system32>npm install --global --production windows-build-tools
npm WARN deprecated request@2.88.2: request has been deprecated, see Request’s Past, Present and Future · Issue #3142 · request/request · GitHub

windows-build-tools@5.2.2 postinstall C:\Users\Salvatore Mo\AppData\Roaming\npm\node_modules\windows-build-tools
node ./dist/index.js

Downloading python-2.7.15.amd64.msi
[> ] 0.0% (0 B/s)
Downloaded python-2.7.15.amd64.msi. Saved to C:\Users\Salvatore Mo.windows-build-tools\python-2.7.15.amd64.msi.
Downloading vs_BuildTools.exe
[> ] 0.0% (0 B/s)
Downloaded vs_BuildTools.exe. Saved to C:\Users\Salvatore Mo.windows-build-tools\vs_BuildTools.exe.

Starting installation...
Launched installers, now waiting for them to finish.
This will likely take some time - please be patient!

Status from the installers:
---------- Visual Studio Build Tools ----------
Successfully installed Visual Studio Build Tools.
------------------- Python --------------------
Successfully installed Python 2.7

Now configuring the Visual Studio Build Tools and Python...

All done!

  • windows-build-tools@5.2.2
    added 144 packages from 98 contributors in 63.678s

C:\Windows\system32>npm install --global node-gyp
npm WARN deprecated request@2.88.2: request has been deprecated, see Request’s Past, Present and Future · Issue #3142 · request/request · GitHub
C:\Users\Salvatore Mo\AppData\Roaming\npm\node-gyp -> C:\Users\Salvatore Mo\AppData\Roaming\npm\node_modules\node-gyp\bin\node-gyp.js

  • node-gyp@7.0.0
    updated 1 package in 4.803s

C:\Windows\system32>npm install johnny-five

@serialport/bindings@8.0.8 install C:\Windows\system32\node_modules@serialport\bindings
prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild

prebuild-install WARN install No prebuilt binaries found (target=14.5.0 runtime=node arch=x64 libc= platform=win32)

C:\Windows\system32\node_modules@serialport\bindings>if not defined npm_config_node_gyp (node "C:\Users\Salvatore Mo\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\....\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node "C:\Users\Salvatore Mo\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" rebuild )
MSBUILD : error MSB1009: Die Projektdatei ist nicht vorhanden.
Schalter: build/binding.sln
gyp ERR! build error
gyp ERR! stack Error: C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\MSBuild\15.0\Bin\MSBuild.exe failed with exit code: 1
gyp ERR! stack at ChildProcess.onExit (C:\Users\Salvatore Mo\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\lib\build.js:194:23)
gyp ERR! stack at ChildProcess.emit (events.js:314:20)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:276:12)
gyp ERR! System Windows_NT 10.0.18363
gyp ERR! command "C:\Program Files\nodejs\node.exe" "C:\Users\Salvatore Mo\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" "rebuild"
gyp ERR! cwd C:\Windows\system32\node_modules@serialport\bindings
gyp ERR! node -v v14.5.0
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok
npm WARN saveError ENOENT: no such file or directory, open 'C:\Windows\system32\package.json'
npm WARN enoent ENOENT: no such file or directory, open 'C:\Windows\system32\package.json'
npm WARN system32 No description
npm WARN system32 No repository field.
npm WARN system32 No README data
npm WARN system32 No license field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @serialport/bindings@8.0.8 (node_modules@serialport\bindings):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: @serialport/bindings@8.0.8 install: prebuild-install --tag-prefix @serialport/bindings@ || node-gyp rebuild
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

  • johnny-five@2.0.0
    updated 1 package and audited 102 packages in 16.618s

1 package is looking for funding
run npm fund for details

found 0 vulnerabilities

C:\Windows\system32>

so ich hatte eine super geile seite gefunden

die hat mir soweit geholfen das phton als fehler weg ist nun habe ich den letzten rest der übrig geblieben ist :frowning:

Meinst Du nicht, dass Du in einem NodeJS-Forum mehr Aussichten hast, Hilfe zu Deinen Problemen zu bekommen?
Deine Probleme haben nichts mit Arduino zu tun.

Gruß Tommy

hm ok danke euch allen ich gucke nach einem node.js forum :slight_smile: