Visual studio code select programmer is not working

Hi,

I am trying to use Visual Studio Code with the arduino extension, so far I managed to set it up, but the "Select Programmer" button on VSC is not giving any option.

I have the 1.8.15 installed and the Arduino extension v.0.4.3

my settings.json

{
    "arduino.path": "C:\\Users\\ocamp\\Documents\\IoTanks\\arduino-1.8.15",
    "arduino.commandPath": "cli\\arduino-cli.exe",
    "arduino.logLevel": "info",
    "arduino.allowPDEFiletype": false,
    "arduino.enableUSBDetection": true,
    "arduino.disableTestingOpen": false,
    "arduino.skipHeaderProvider": false,
    "arduino.additionalUrls": [
        "http://arduino.esp8266.com/stable/package_esp8266com_index.json"
    ],
    "arduino.defaultBaudRate": 115200
}

I read similar problems in some other forum
https://www.gitmemory.com/issue/microsoft/vscode-arduino/1298/883547080

https://github.com/microsoft/vscode-arduino/issues/1298

but they recommend using the cli and i have another issue with the cli... cli issue

is anyone aware of such bug/issue?

I don't have any experience with the VS Code extension, but I notice you have the ESP8266 Arduino boards platform in your additional URLs and that the ESP8266 boards platform does not define any programmers:
https://github.com/esp8266/Arduino/blob/master/programmers.txt

So at least in the official Arduino IDE and Arduino CLI, it is normal and expected that no programmers are listed for the ESP8266. You can either upload to these boards over the serial port or else OTA if using the standard Arduino IDE (Arduino CLI doesn't have the network ports support yet). But maybe "programmer" has a different meaning in the VS Code extension. or maybe you're using a board that does have programmers.

1 Like

I removed all additional boards and still the Select Programmer is not showing any options.

this is my settings.json now (i also removed the cli altogether due to other problems.

{
    "arduino.path": "C:\\Users\\ocamp\\Documents\\IoTanks\\arduino-1.8.15",
//    "arduino.logLevel": "info",
    "arduino.allowPDEFiletype": false,
    "arduino.enableUSBDetection": true,
    "arduino.disableTestingOpen": false,
    "arduino.skipHeaderProvider": true,
    "arduino.additionalUrls": [
        
    ],
    "arduino.defaultBaudRate": 115200
}

and my arduino.json (is this file necessary?)

{
    "configuration": "cpu=atmega328old",
    "board": "arduino:avr:nano",
    "port": "COM3"

}

should I add something like "programmer": "AVRISPmkii", in the .json?

Thanks your your help! i really like the new forum!! For the ones that do not have a strong IT background is very encouraging finding someone to ask... :+1: :love_you_gesture: :ok_hand:

Unfortunately, as I mentioned before I don't have any experience with the VS Code extension. I'm glad it exists, and am especially happy that they are integrating Arduino CLI now rather than solely relying on Arduino IDE, but I have enough trouble keeping up with the Arduino IDE, Arduino IDE 2.x, Arduino CLI, and Arduino Web Editor without adding another development platform to my plate (though I do use VS Code all day every day for general development work).

So I'm not well equipped to answer your questions. I'm certain we have other forum members who are experienced with the VS Code Arduino extension though.

Hey there,

I just had the same situation but was able to solve it.
I couldn't even select a Board.
So you need an Arduino plugged in (UNO in my case) and you have to look up it's COM port.
then you need to change the port in the arduino.json file.
after that you click "show board config" and select your board.
Now the "select programmer" option should work.
I am by no means an Expert I^m just stating how it worked in my case.

if it doesn't work, here's my arduino.json file:

{

 "sketch": "Blink.ino",

 "port": "COM5",

 "board": "arduino:avr:uno",

 "programmer": "arduino:avrisp"

}

1 Like