VODAFONE STATION e ARDUINO

Avevo una station vodafone, funzionava tutto, come client e come server (un uso domotico),
sostituita la vodafone è reimpostati i parametri uguali come prima Arduino NON mi invia niente
ma riceve tranquillamente i comandi e li esegue. La contro-risposta di conferma, quindi il GET per scrivere su MYSQL non va..( per avere una specie di storico)
la funzione
GET /ARDUINO.asp?Azione=ON&Comando=33

usando questo metodo
Client.println("GET /ARDUINO.asp?Azione=ON&Comando=33");
Client.println("Host: www.ilmiosito.it");
Client.println("User-Agent: arduino-ethernet");
delay(300);
Serial.print("inviata stringa");
Serial.print("\n");
Client.println("Connection: close");
Client.println();
Client.stop();

i parametri di vodafone sono:

Port Forwarding
Indirizzo locale: 192.168.0.102
Protocollo TCP
Porta esterna 102
Porta interna 80

Port triggering
Protocollo in uscita TCP
Porte in uscita 112
Protocollo in ingresso TCP
Porte in ingresso 102

cosa sarà successo?
se volete sapere qualche dettagli in più chiedetemi, al fine di risolvere questo problema che
mi è successo....
ps: E' POSSIBILE CHE LA SCHEDA ETHERNET, RICEVA SOLO I COMANDI E NON LI TRASMETTA,
SI PUO' DANNEGGIARE SOLO A META'?

La vodafone station al primo collegamento con un nuovo device vuole che si prema un tasto nella pagina web che su un PC appare automaticamente.

il device (arduino) lo riconosce. lo vedo collegato (192.xxx.xxx.xxx)
Spiego
Apro pagina HTML sul server del mio dominio
mi fa vedere la pagina con i vari comandi,
invio il comando
arduino riceve e esegue il comando, quindi led acceso o quindi led spento
dopo che arduino esegue il comando invia una stringa
"GET .........."
questa stringa in effettivo NON parte sembra che arduino in effettivo NON invii la stringa.
se la stessa stringa la faccio in manuale riportando il link nel browers, la pagina ASP, html, php, la esegue e scrive sul MYSQL
quindi pagina funziona, unica cosa che NON funziona è che arduino NON invia la stringa.
Problema ?!?!?!?!

Se hai una vodafone station 2 o revolution probabilmente succede ciò che ti ha detto flz47655.
La spiegazione e la soluzione la trovi qui:
http://www.francescovolani.org/techlog/?p=63

Edit Linnk corretto! Grazie a bitmanrc per la segnalazione.

ZOOMX Link non funzionante
aggiustato in http://www.francescovolani.org/techlog/?p=63

ok semplice
vodafone.station/?page=dashboard_wizard.html&host_mac=qui indirizzo mec

esempio
vodafone.station/?page=dashboard_wizard.html&host_mac=00:00:00:00:00:00

Vale sia per Arduino che per qualsiasi dispositivo mancante di browser, come spiegato nell'articolo.
Se usi l'ESP8266 devi mettere il MAC dell'ESP che puoi ricavare dall'interfaccia web della VS2 quando si è collegato.

si compreso........... :slight_smile:
:slight_smile: