Voice recognition module not working when 4-DC motor chassis is connected

I am using elechouse v3 voice recognition module to control my 4wheel 4-DC motor chassis. I am giving 12V to the L298N driver board and taking 5V from the board to power up the Arduino Uno. The voice recognition works (and result is displayed on the serial monitor) when Uno is connected to the PC via USB but the moment I provide 12V to the chassis, the module stops recognizing speech. What can be the possible problem? I even tried attaching chassis and voice recog module to two different arduino but still the same problem was happening. Please help!

Help is not possible until you supply a schematic that shows how YOU have everything wired together.

Paul

I’m guessing you have a problem in your wiring.

Thanks for your help :) . It was an issue with the power source. I was using a 12 V adapter for testing purpose. When I used a LiPo battery, its working fine. May be there is some problem while using a converted AC supply.

May be there is some problem while using a converted AC supply.

No both should work fine.

You have some other problem, what that is we can only guess because you are not supplying the relevant information.

Ok. I will post the circuit diagram shortly.

Can you please share the code