W5100 power up issue (just start after pressing reset)

Hi, I have exactly the same problem on both device. Mega2560 boards, w5100 ethernet shields ( local made, and the other is hanrun ). Using an external power supply (stable adapter using 9V DC...) after power up, the wiznet shield 'hanging' and nothing happens, just blinking a yellow led on it. After pressing the RESET button on the shield, it is starting, and working fine! I have tried the followings: - changed to another type of adapter with 7V, 9V, 12V also -> nothing changed - tried to use the RC low pass filter what can be found on the internet to fix this issue ( 10K resistor between Reset and 3.3v and 10nF capacitor between reset and GND, also with 20nF, and isolating the Reset also ) -> nothing changed - tried to find any topic here about the fix, but haven't...

I was thinking about how to fix it??? - should use the USB input with the current power adapter ( because the problem happen only on power input plug ) with creating a cable between the USB input and the DC adapter? - should somehow reset the w5100 at the first start ( setup ) , but how? ( like this: http://www.instructables.com/id/two-ways-to-reset-arduino-in-software/#step1 but this will reset over and over...) - watchdog timer? But I need to modify the bootloader?

Please help to find the solution! Thanks!

At least you have to supply schematics for the shields you're using, otherwise you probably won't get any helpful comment as we have no clue what's connected how in your setup.

ok, sorry. So the setups:

  1. mega2560 arduino board, wiznet5100 local made sitting on it. Using six pieces of 1wire ds18b20 and connecting to a router. this wiznet shield does not have isp on the bottom.
  2. funduino 2560 board with hanrun wiznet5100 shield. Using 5 ds18b20 on 1wire and dht11 on digital pins. Shield using ISP to connect to the board. For both of them exactly the sami problem I have. I do not have to reset only in case of connecting to my laptop with USB. It is no matter what kind of skecth does it have, just right after power up, the shield are not starting...

What kind of schematics should I give? (sorry for the question, but i do not understand.) I do not have any documentations about the shields unfortunately.

What kind of schematics should I give? (sorry for the question, but i do not understand.) I do not have any documentations about the shields unfortunately.

Without schematics we couldn't give you hints how to fix that because it's probably a hardware problem. If you have nothing else (not even a link to where you bought it), make sharp pictures of both sides of the board and post them. Maybe they provide enough details to find the problem.

I have attached a picture about the board and the shield. I have tried to put a larger delay at the beginning of the setup(). No change.
It is only working fine, in case of pressing the reset, or in case of using the serial monitor...
:~
Thanks!

Old info that might be of interest.

http://marco.guardigli.it/2010/11/arduino-wiznet-ethernet-shield-proper.html

Thanks, but this is the RC low pass filter. Already tried that, but no change...